IDEA makes Windows XP SP2 clock run faster

Hi!

I have a veeeery strange Problem here.
I have a PC with Windows XP Pro SP2 and all updates. I have installed Various applications (from big ones like MS Office 2003 & 2007 beta to small ones like Winamp, Spybot S&D and others)
I have got JDK 1.5.0 realease 1 to 10 and Java6 final and Java 6u1 b04. I have got installed Idea 5.1.2, Idea 6.0.2 and Idea build 6137. And I have installed Sybase ASA 9 Database.
(if you need more info pleae ask)

I noticed, that my System clock is running much to fast. So I booted with a Linux LiveCD to check it and there the clock runs at normal speed. So It needs to be some windows feature or windows application. I disabled automatic time synchronization in Windows and worked that way for a few days with numerous reboots to ensure that there is no lazy time correction or other stuff running.
Next I tried to disable non-vital services and applications. All no succes.
But now I discovered, that when I click on the IntelliJ Icon in my Quicklaunch bar a few seconds after the splash-screen is shown, my clock runs about 20-50% faster.
When I close intellij the clock instantly slows down and runs at normal speed.

I have no clue why that happens (and I think you wont have to at a first glance) but maybe we could find a solution for this...

Thanks in advance for your time and effort!

nomike aka Michael Postmann

10 comments
Comment actions Permalink

this is normal space-time bending - see relativity theory.
IDEA just runs too fast :)

0
Comment actions Permalink

Maybe this is related to the severe bug in the use of the millisecond clock
value in Windows that shows up in Java quite heavily. See e.g.
http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6435126

For us it helped to use -XX:+ForceTimeHighResolution VM switch. It might be
IDEA runs somewhat slower, but the oppisite might as well be true (as in our
case fortunately).

Ciao

...Jochen

"Michael Postmann" <no_reply@jetbrains.com> wrote in message
news:20399523.1166519476120.JavaMail.itn@is.intellij.net...

Hi!

>

I have a veeeery strange Problem here.
I have a PC with Windows XP Pro SP2 and all updates. I have installed
Various applications (from big ones like MS Office 2003 & 2007 beta to
small ones like Winamp, Spybot S&D and others)
I have got JDK 1.5.0 realease 1 to 10 and Java6 final and Java 6u1 b04. I
have got installed Idea 5.1.2, Idea 6.0.2 and Idea build 6137. And I have
installed Sybase ASA 9 Database.
(if you need more info pleae ask)

>

I noticed, that my System clock is running much to fast. So I booted with
a Linux LiveCD to check it and there the clock runs at normal speed. So It
needs to be some windows feature or windows application. I disabled
automatic time synchronization in Windows and worked that way for a few
days with numerous reboots to ensure that there is no lazy time correction
or other stuff running.
Next I tried to disable non-vital services and applications. All no
succes.
But now I discovered, that when I click on the IntelliJ Icon in my
Quicklaunch bar a few seconds after the splash-screen is shown, my clock
runs about 20-50% faster.
When I close intellij the clock instantly slows down and runs at normal
speed.

>

I have no clue why that happens (and I think you wont have to at a first
glance) but maybe we could find a solution for this...

>

Thanks in advance for your time and effort!

>

nomike aka Michael Postmann




0
Comment actions Permalink

Sound good, but I think there must be more. It's not only the problem that IntelliJ runs to fast/slow or doesn't measure time-frame correctly, it is that my whole Windows Clock runs faster when I start intelliJ. IntelliJ does read the clock, but it should not modify or set it, shouldn't it?
Also this bug isn't allways replicable (only aprox. 8 of 10 times)

it's getting more and more stranger...

nomike aka Michael Postmann

0
Comment actions Permalink

Hello Michael,

We have seen that problem several times. Every time that was caused by some
kind of hardware problem. Do you happen to have dual-core Athlon CPU? If
so, this link might be useful: http://www.hardforum.com/showthread.php?t=983781

Best regards,

Vladislav Kaznacheev
Project Manager, IntelliJ IDEA
http://www.jetbrains.com
"Develop with Pleasure!"

Hi!

I have a veeeery strange Problem here.

I have a PC with Windows XP Pro SP2 and all updates. I have installed
Various applications (from big ones like MS Office 2003 & 2007 beta to
small ones like Winamp, Spybot S&D and others)

I have got JDK 1.5.0 realease 1 to 10 and Java6 final and Java 6u1
b04. I have got installed Idea 5.1.2, Idea 6.0.2 and Idea build 6137.
And I have installed Sybase ASA 9 Database.

(if you need more info pleae ask)

I noticed, that my System clock is running much to fast. So I booted
with a Linux LiveCD to check it and there the clock runs at normal
speed. So It needs to be some windows feature or windows application.
I disabled automatic time synchronization in Windows and worked that
way for a few days with numerous reboots to ensure that there is no
lazy time correction or other stuff running.

Next I tried to disable non-vital services and applications. All no
succes.

But now I discovered, that when I click on the IntelliJ Icon in my
Quicklaunch bar a few seconds after the splash-screen is shown, my
clock runs about 20-50% faster.

When I close intellij the clock instantly slows down and runs at
normal speed.

I have no clue why that happens (and I think you wont have to at a
first glance) but maybe we could find a solution for this...

Thanks in advance for your time and effort!

nomike aka Michael Postmann



0
Comment actions Permalink

No I have a P4-HT. And the Problem just occures when IntelliJ runs, it doesn't occur in bios, linux liveCD or when intelliJ is not running...

nomike aka Michael Postmann

0
Comment actions Permalink

Hi Michael...

Thats the really bad thing about this bug, that it changes the global system
clock :-).

Ciao

...Jochen

"Michael Postmann" <no_reply@jetbrains.com> wrote in message
news:16103936.1166531703428.JavaMail.itn@is.intellij.net...

Sound good, but I think there must be more. It's not only the problem that
IntelliJ runs to fast/slow or doesn't measure time-frame correctly, it is
that my whole Windows Clock runs faster when I start intelliJ. IntelliJ
does read the clock, but it should not modify or set it, shouldn't it?
Also this bug isn't allways replicable (only aprox. 8 of 10 times)

>

it's getting more and more stranger...

>

nomike aka Michael Postmann




0
Comment actions Permalink

the Problem just occures when IntelliJ runs

There must be something wrong with my hand: Everytime I hold it front of my eyes I hurt myself when I bang into stuff. Never happens when have my hand elsewhere.

Sorry couldn't help that.

Really do try the fixes there. It's not Idea that has the bug even if it is Idea that triggers the bug.

0
Comment actions Permalink

Thx, this fixed the issue.
Seems to be very hardware dependent, because none of my friends was able to reproduce it....

nomike aka Michael Postmann

0
Comment actions Permalink

A colleague of mine came across a similar problem with the system clock speeding up on Windows for some users when our application was running.

He tracked it down to a bug in JDIC, specifically to a while (true) loop in a thread that used microsleeps (less than 10ms). This upsets the system clock because of a JVM bug (sorry, can't remember bug id now, should be easy to find).

I think the bug was specific to 1.4 (according to the bug database) but we saw it with Java 5 JVMs also.

Patching JDIC and setting the sleep time to >10ms made the problem go away.

0
Comment actions Permalink

Just install Eclipse. It will slow down your system enough to balance things out.

0

Please sign in to leave a comment.