Local history just failed. Miserably...

Hi there,

I'm using 6111 and just had a really unpleasant experience with it: relying
on a label in local history to bring back some external changes does not
work.

Here's the flow: changes made to some files. Prior to externally overwriting
them (the check-out process of the version control tool I have to use overwrites
the local files) I set a label on an entire directory structure. Then I check-out,
happily going back to IDEA to get my changes into the files. The label is
there, but the files are identical, no record of the external change.

Also, I have the local history set to automatically label on all the possible
actions. There simply are no entries for compile or make (which I had a few
and I could have reverted to those ones).

Quite dissapointing... :(

Andrei


2 comments
Comment actions Permalink

I have seen this kind of thing a couple of times. I know it's not
reliable, so before doing any big change I take an external backup. If
local history revert works then so much the better and if it fails I
have my external backup.

But it's not the kind of bug I want to spend any time reproducing since
it only occurs at critical moments :(

See also
http://www.intellij.net/forums/thread.jspa?messageID=5172354
R

0
Comment actions Permalink

Hello Robert,

RG> I have seen this kind of thing a couple of times. I know it's not
RG> reliable, so before doing any big change I take an external backup.
RG> If local history revert works then so much the better and if it
RG> fails I have my external backup.

Yeah, I'll keep that in mind...

RG>
RG> But it's not the kind of bug I want to spend any time reproducing
RG> since it only occurs at critical moments :(

The one when make/compile does not create entries in the local history (in
spite of the setting) is quite consistent, I just verified it few times yesterday.

RG>
RG> See also
RG> http://www.intellij.net/forums/thread.jspa?messageID=5172354 R

I see, let's hope jetbrains hear our cry... :)

Best,
Andrei


0

Please sign in to leave a comment.