Additional Compiler Options

Of course, it may be because I am tired, since I haven't been able to get my debugger to work, but that was an issue I wanted to address after I work this one out.  

I've been using Flex with web services for some years now, but now I am switching from Microsoft to PHP.  I know that Flex itself cannot communicate with a database directly, so I am using AMFPHP to act as the middle man between Flex and PHP and the DB.  For the most part I have my system configured (running locally right now), but for this to work, I need to add a service-config.xml to my compiler options.

From the Compiler Option tab within the module, I added the services option (circled in green in image).  I placed the xml file within a specific directory within my structure (I've also placed it at the root, but that didn't work either), and with I attempt to compile I get the same error "unable to open...", also circled in green.  If you look at the red oval, you can see that the path within my compiler string matches that of my structure, so can anyone tell me why the IDE is unable to open the file (which I've attached as well).

IntelliJ11_Compiler.png
Any help would be greatly appreciated, as I've been working this issue all day and am at a stopping point.  Really can't test any further is I can't compile the system with the necessary xml file.  Also, I've verified that the XML file is properly formatted.



Attachment(s):
services-config.xml
2 comments
Comment actions Permalink

Okay, disregard, I figured it out.  Seems I don't need the forward-slash and I was looking at this from a web site instead of a directory site.  it should have been: -services "src\com\assets\xml\services-config.xml", which seems to work fine.  Still not sure why I couldn't put it at the root of the directory structure, but no time to worry about that, I have to get my debugger to work again.

0
Comment actions Permalink

Sorry for delay, just came back after vacation.
Note that it is recommended to configure compiler options in the table at the top part of the Compiler Options tab instead of using Aditional compiler options field if the table contains required option. You can safely remove "-locale en_US" from Additional optionbs field as it is already used by default (see 3rd line of the table). And istead of setting -services option just select your services-config.xml file using file chooser of the "Data Services config file" node (under Server Technology node in the table).

0

Please sign in to leave a comment.