Want no ^M eol when running IDEA on Windows but mounting a Unix fs

When you are running IDEA on WindowsXP and samba mounting a remote filesystem on UNIX where all your project files reside, is there a way to force IDEA's cvs integration to honor the UNIX end-of-line and not introduce ^M? I find that when I do a checkout or sometimes update, that cvs in IDEA wants ^M. I'm on the latest 6.0.2 EAP.

2 comments

You could try setting the "Line Separator" option in Settings -> (Project|Global) Code Style to "Unix". However this is a global option that isn't CVS-related.

Sascha

0

Hey Sascha - That does the trick including when you do cvs commands like checkout. I was a little surprised as I had the impression that this would only apply when you created a file from IDEA.

A nice additional option for Line Separator would be "Filesystem Dependent" and change the existing "System Dependent" to be 'Operating System Dependent". I wonder if it is possible for IDEA to detect the type of filesystem.

0

Please sign in to leave a comment.