Questions about subversion 1.4 support in latest EAP build

Hi there,

I have a question about the svn 1.4 support in the newly released build:
will this automatically upgrade my local version to the new format (like
other svn clients do)? If I use the new IDEA 6068 build, will I be able to
open the same project with the released 6.0.1 in case I have to and still
have full svn support?

Thx,
Andrei


5 comments

Hello Andrei,

AO> I have a question about the svn 1.4 support in the newly released
AO> build: will this automatically upgrade my local version to the new
AO> format (like other svn clients do)? If I use the new IDEA 6068
AO> build, will I be able to open the same project with the released
AO> 6.0.1 in case I have to and still have full svn support?

It prompts you whether the upgrade should be performed. You'll be able to
use 6.0.1 if you do not upgrade, and won't be able if you do.

--
Dmitry Jemerov
Software Developer
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0

It asks if you wish to update your local version to the new format. I imagine if you do so, you'll have the same problems with opening against 6.0.1 as people who used other tools with svn 1.4 support before.

--Dave Griffith

0

Hello Dmitry,

DJ> It prompts you whether the upgrade should be performed. You'll be
DJ> able to use 6.0.1 if you do not upgrade, and won't be able if you
DJ> do.

That's great, just what I was hoping for. :)

Thx,
Andrei


0

Will a 1.4 local version work with a 1.3 server?

Dmitry Jemerov wrote:

Hello Andrei,

AO> I have a question about the svn 1.4 support in the newly released
AO> build: will this automatically upgrade my local version to the new
AO> format (like other svn clients do)? If I use the new IDEA 6068
AO> build, will I be able to open the same project with the released
AO> 6.0.1 in case I have to and still have full svn support?

It prompts you whether the upgrade should be performed. You'll be able
to use 6.0.1 if you do not upgrade, and won't be able if you do.

0

Peter wrote:

Will a 1.4 local version work with a 1.3 server?

Yes. I'm running a 1.4 client against a 1.2 server.
R

0

Please sign in to leave a comment.