Build 5734 and 'scanning output directories ..'

I'm seeing some very long scan times when I'm running unit tests against build 5734. Are there any settings I can check to verify that I've got things setup correctly? It happens on every run of the unit tests and it's taking about 30 seconds a scan... which makes testing painful.


Regards,

Bruce Ritchie

10 comments

This should not happen every time, I expect long pauses only on the first make of the project after IDEA startup. Or you clean output directories between junit sessions? Anyway, there are plans to remove scanning phase at all, and we'll do our best to make it happen in 6.0.1

0

I've also been seeing long scan times on every Make - including before re-running a single unit test. This does not occur for the same project file in version 5.1.2.

This is quite disruptive to the code, test, refactor style of working as there is at least a 20s delay before a test will run.

Is there no way to turn off the scanning phase?

Thanks
Giles

0

Eugene,

It does happen everytime, and I'm not the only one on my team that's seeing this. We're also seeing it on app runs (using webwork's quickstart tool). We're not cleaning output directories at all, and the pattern of the issue doesn't seem to be I/O related - I see one of my cpu's at 100% during the scanning phase.


It would be really great to have this scanning phase completely removed - as it stands right now we're having to go back to 5.1 because this issue is slowing down our development just too much.


Regards,

Bruce Ritchie

0

Please check how many "unversioned files" are listed in the "Changes" toolwindow?

--
Best regards,
Eugene Zhuravlev
Software Developer
JetBrains Inc.
http://www.jetbrains.com
"Develop with pleasure!"


0

Eugene,

Currently I see 6 changes, 5 modified, 1 added. Two of the modified files are the project's .iml and .ipr files, the rest are .java files.

Upon running a unit test class I see the changed files being compiled then a bunch of information about some .jspf files being excluded from validation. Perhaps jsp validation is the issue ? I do know that the option to run jasper validation on jsp files is unchecked for the module (single module project) so I'm a bit uncertain why the jsp's look like they are being validated.

As well we do have some excludes in our project including the target output directory.


Regards,

Bruce Ritchie

0

Hmm, then may I ask you to take a CPU snapshot like described here: http://www.jetbrains.net/jira/browse/IDEA-9717
The issue seems to be a report of the similar problem.

--
Best regards,
Eugene Zhuravlev
Software Developer
JetBrains Inc.
http://www.jetbrains.com
"Develop with pleasure!"


0

Eugene,

I've updated that issue with a snapshot as described in the issue.


Regards,

Bruce Ritchie

0

Thanks Bruce, see my comments there.

I've scheduled the issue to be fixed ASAP: http://www.jetbrains.net/jira/browse/IDEADEV-10593
As a workaround, please uninstall the Struts plugin.

--
Best regards,
Eugene Zhuravlev
Software Developer
JetBrains Inc.
http://www.jetbrains.com
"Develop with pleasure!"

"Bruce Ritchie" <bruce@jivesoftware.com> wrote in message news:5228435.1159988305654.JavaMail.itn@is.intellij.net...

Eugene,

>

I've updated that issue with a snapshot as described in the issue.

>
>

Regards,

>

Bruce Ritchie



0

I was having a similar problem with scans. I uninstalled the Struts plugin (and, admittedly, a bunch of other plugins I'll never use) and that seemed to clear it up. However, I still see the message window flash telling me all my JSPs are being excluded from validation, so it's still a little annoying.

0

Hello Robert,

This problem is already reported (http://www.jetbrains.net/jira/browse/IDEADEV-10769).

I was having a similar problem with scans. I uninstalled the Struts
plugin (and, admittedly, a bunch of other plugins I'll never use) and
that seemed to clear it up. However, I still see the message window
flash telling me all my JSPs are being excluded from validation, so
it's still a little annoying.



0

Please sign in to leave a comment.