Maven hangs after build

Hi,

when I build a maven project the IDE hangs (does not take any commands) about 30 seconds after the complection of the build. It looks like this:

....
some maven build output
....


[INFO] ------------------------------------------------------------------------
[INFO] BUILD SUCCESS
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 3:21.925s
[INFO] Finished at: Thu Aug 02 10:16:13 CEST 2012
[INFO] Final Memory: 42M/508M
[INFO] ------------------------------------------------------------------------


.... 30 seconds ....

Process finished with exit code 0




It is pretty annoying....

I use IntelliJ Version 11.1.3, os is windows xp ansd maven version is 3.0.4. As expected the mvn console build is finished right after the success message....
1 comment
Comment actions Permalink

This is an unusual occurrence. One neither I nor my co-workers experience. I recommend the following: Disable any third-party plugins (i.e. ones not bundled with IDEA), restart IDEA and see if the issue persists.If the issue is gone, re-enable plug-ins one by one until the issue resurfaces to find the culprit. Often, issues like this are a result of a bug in a plug-in. (And the plug-in may not have anything to do with Maven.) If that does not solve the issue, I recommend you follow the instructions from the document How to report IntelliJ IDEA performance problems and take CPU snapshots to report the performance problem so the JetBrains developers determine the problem and either provide you with a solution, or fix any bugs in IDEA.

0

Please sign in to leave a comment.