Slow typing again

Hello,

I had this problem occuring in the past.

While using IntelliJ 10, I think I almost never had it.

But now, with IntelliJ 11.1.2, it's happening often again: slow response while typing.

When typing characters in java code, IntelliJ is responding really sluggish and slow.

It really seems slower than 10 to me.

Why?

How can I stop it again?

Why does it have to parse stuff while I type? Can't it give preference to what I'm doing? I can wait a few seconds for an autocompletion, but I cannot wait more than 50ms for a letter appearing on the screen after I typed it...

Thanks.

5 comments
Comment actions Permalink

Please submit a CPU snapshot as described in http://devnet.jetbrains.net/docs/DOC-192

0
Comment actions Permalink

I'm sorry, it's not that easy right now to send a CPU snapshot due to various reasons (including it containing confidential data).

But I think I have a clue why it's slow!

On the left side of IntelliJ (by default) you have the "Project" that shows all the directories and packages. Whenever doing *anything* in IntelliJ, in the top right of that, it shows a small circular animated loading indicator in the top right of that, as if it's refreshing the whole list.

When typing text, it also does that all the time (but not when not typing)!

Is there a way to disable the whatever it's doing while typing text?

Thanks!

0
Comment actions Permalink

exactly what happened to me, but i have not noticed it for some time now, maybe it got little fixed or SSD solved it.
either way, i confirm that when i type the indicator moves always.

I would try to disable all the plugins.

0
Comment actions Permalink

You can try hiding any of the toolwindow(s) you suspect slowing down your typing. And, as suggested, try turning off one plugin by another until you see an improvement.

0
Comment actions Permalink

so now when Iam aware of this, it started to annoy me too.
so I created an issue http://youtrack.jetbrains.com/issue/IDEA-89725

0

Please sign in to leave a comment.