IntelliJ IDEA 6.0 is available

Hello everyone,

We're happy to announce the final release of IntelliJ IDEA 6.0. The final
release is available at the usual location: http://www.jetbrains.com/idea/download/index.html

On behalf of the entire JetBrains team, I would like to express my thanks
to everyone who participated in the EAP program. We implemented hundreds
of new features and fixes that were directly influenced by your feedback.
Hope to see you all again in the EAP for the next version. :)

(And we're sorry for some glitches you may see on our Web site today - we're
still making last-minute tweaks.)

--
Dmitry Jemerov
Software Developer
http://www.jetbrains.com/
"Develop with Pleasure!"


39 comments
Comment actions Permalink

Quick question: Is the final build still 5755?

0
Comment actions Permalink

Congratulations!

--Dave Griffith

0
Comment actions Permalink

Hello Gordon,

GT> Quick question: Is the final build still 5755?

It's build 5766, with a few fixes which were not included in 5755.

--
Dmitry Jemerov
Software Developer
http://www.jetbrains.com/
"Develop with Pleasure!"


0
Comment actions Permalink

Congratulations from me, too!
I guess each of you could use a long, relaxed holiday...

... but wait where's 6.0.1 EAP? :))

Gordon, the about dialog says it's build 5766. Jira shows a couple of fixed issues for
builds 5756...5766.

0
Comment actions Permalink

Hello Stephen,

SF> Congratulations from me, too!
SF> I guess each of you could use a long, relaxed holiday...
SF> .. but wait where's 6.0.1 EAP? :))

It'll be up in a few days.

--
Dmitry Jemerov
Software Developer
http://www.jetbrains.com/
"Develop with Pleasure!"


0
Comment actions Permalink

Congratulation :)

But is there anyone here has problem with Tomcat? I cannot start Tomcat when I configure it to run in local. I always has "Error running Test: Address localhost:8080 is already in use". Even I change "localhost" to machine name in "Startup page" but still has same message. Project can deploy well.

I have this problem with latest EAP (build 5755) and IDEA 6 (build 5766)

0
Comment actions Permalink

Congratulations on getting it out the door.

Small bug, on the front page of jetbrains.com, in the flash animation, "Continuous" is misspelled as "Continuos"

0
Comment actions Permalink

Good job and congrats on the release :)

It's got some rough edges, but I guess that makes waiting for 6.0.1 more fun ;)

Sascha

0
Comment actions Permalink

Congratulations! Great release, well done!

Bas

0
Comment actions Permalink

When trying to purchase a personal upgrade license the purchase fails. The transfer from JetBrains to Element5 shows an error page - invalid link.

0
Comment actions Permalink

Congratulations! I'm eagerly awaiting 6.01 ;)

0
Comment actions Permalink

>When trying to purchase a personal upgrade license the purchase fails. The transfer from >JetBrains to Element5 shows an error page - invalid link.


Just tried the same, and get an error page linking from jetbrains to element5.

Let us know when this is fixed so we can purchase/upgrade.

-Lloyd-

0
Comment actions Permalink

I stopped Tomcat service also when I run "netstat -na", nothing relates with port 8080.

0
Comment actions Permalink

Hello Lloyd,

Just checked, works fine.
Thanks for interest BTW :)

-


Maxim Shafirov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

>> When trying to purchase a personal upgrade license the purchase
>> fails. The transfer from >JetBrains to Element5 shows an error page -
>> invalid link.
>>

Just tried the same, and get an error page linking from jetbrains to
element5.

Let us know when this is fixed so we can purchase/upgrade.

-Lloyd-



0
Comment actions Permalink

I got the failure, also. Emailed Jetbrains sales and he recommended I use the link:

https://sshop.element5.com/esales/checkout.html?PRODUCT[300080831]=1

--Tim

0
Comment actions Permalink

When I tried to make a purchase, I see:

An error has occurred
The link you used is not valid.

0
Comment actions Permalink

Hello Kendall,

Sorry for asking but could you please provide the steps you were following
that lead to that error? Like what product, new user or upgrade, personal
or commercial etc.
I've just done a few sequences again and everything works just fine.

Thanks

-


Maxim Shafirov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

When I tried to make a purchase, I see:

An error has occurred
The link you used is not valid.



0
Comment actions Permalink

I was purchasing a personal license upgrade. After supplying my current license key to a popup, I provided contact information (name, address, email) and payment method, I pressed Proceed to Payment and, on the next page (which an informational page that starts with "The credit card transactions are securely processed by Element 5."), pressed Continue. At this point, I get the error page I described above.

0
Comment actions Permalink

Hello Kendall,

OK, thanks a lot, that's it - personal license upgrade.
Will be fixed ASAP.

-


Maxim Shafirov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

I was purchasing a personal license upgrade. After supplying my
current license key to a popup, I provided contact information (name,
address, email) and payment method, I pressed Proceed to Payment and,
on the next page (which an informational page that starts with "The
credit card transactions are securely processed by Element 5."),
pressed Continue. At this point, I get the error page I described
above.



0
Comment actions Permalink

Once again, great job and congratulations!

Now, what can we expect to see in 6.5? :P

0
Comment actions Permalink

My company's proxy blocks the downloading of .exe files... (therefore I cannot download the 6.0 release) --- are you going to make build 5766 available on EAP so we can get it (I've been using that to download the .zip files all along now).

0
Comment actions Permalink

Marc Stock wrote on 02/10/06 23:05:

Now, what can we expect to see in 6.5? :P


Shipped/supported Groovy, Jython, JRuby, Scala, Semplice (the SUN Visual
Basic compiler?) could be rockin ;)

0
Comment actions Permalink

Congratulations to the whole team!


Regards,

Bruce Ritchie

0
Comment actions Permalink

Congratulations!

0
Comment actions Permalink

Hello, anybody there?

I know my problem sounds stupid but if any service/program used port 8080, I cannot start Tomcat anymore. But actually I can start/stop Tomcat service anytime. (before I run my web application in IDEA, I stopped the service)

If I change Tomcat to port 8085, it will work well.

0
Comment actions Permalink

My guesses?

Cross-project refactoring, including drag and drop and universal in-place rename.
Many visualizations (take the graph API out for a spin!)
Remote dependencies (probably coupled with Maven integration)
Tooling for Hibernate and Spring, possibly Tapestry and OSGi.
More teamware.
Moves toward code review automation.

Well, I can dream, anyway.

--Dave Griffith

0
Comment actions Permalink

Not corect place for bug reports I think, please try Jira or J2EE forum.

0
Comment actions Permalink

Hello t800t8,

This problem may be caused by firewall software.

Congratulation :)

But is there anyone here has problem with Tomcat? I cannot start
Tomcat when I configure it to run in local. I always has "Error
running Test: Address localhost:8080 is already in use". Even I change
"localhost" to machine name in startup page but still has this
problem. Project can deploy well.

I have this problem with latest EAP (build 5755) and IDEA 6 (build
5766)



0
Comment actions Permalink

Thanks Dmitry.

It's better than say nothing ;)

http://www.jetbrains.net/jira/browse/IDEA-9689

0

Please sign in to leave a comment.