Automatic Compile in 5374

Since I have updated to #5374, Intellij compiles my project everytime it loses focus. I have not seen this behavior before and it is causing a real headache with dubugging my webapp. Is this a new feature that has been slipped in and is there a way to turn it off??

3 comments

Hello Mark,

MR> Since I have updated to #5374, Intellij compiles my project
MR> everytime it loses focus. I have not seen this behavior before and
MR> it is causing a real headache with dubugging my webapp. Is this a
MR> new feature that has been slipped in and is there a way to turn it
MR> off??

It's an old feature that was broken for a long time. Settings | Project Structure
| Java EE Build Settings | Build on frame deactivation.

--
Dmitry Jemerov
Software Developer
http://www.jetbrains.com/
"Develop with Pleasure!"


0

That worked. Thank you for the very quick reply!

0

Hello Mark,

Yep, it can be switched off on Web Module's settings Build page.
We'll switch that off by default in next build.

-


Maxim Shafirov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

Since I have updated to #5374, Intellij compiles my project everytime
it loses focus. I have not seen this behavior before and it is causing
a real headache with dubugging my webapp. Is this a new feature that
has been slipped in and is there a way to turn it off??



0

Please sign in to leave a comment.