How do I run Intellij 11 in 64-Bit mode in Win-7?

How do I run Intellij 11 in 64-Bit mode in Win-7? I have seen comments for Intellij 10 to run idea64.exe (or something to that effect), but it doesn't exist in IntelliJ 11. Is there a different installer? Searching the docs finds nothing on 64-bit.

Comment actions Permalink

Really, not a single reply for such a basic question, this is amazing? So I'm to assume Intellij 11 doesn't support 64-bit mode I guess. I sure would be nice if Intellij developers would read this discussion board.

Comment actions Permalink

The bin directory of the IntelliJ 11 installation should have a idea.exe and idea64.exe.  

My installation has them located here:

C:\Program Files (x86)\JetBrains\IntelliJ IDEA 11.0.1\bin\idea.exe
C:\Program Files (x86)\JetBrains\IntelliJ IDEA 11.0.1\bin\idea64.exe

Likewise there's a idea.exe.vmoptions and idea64.exe.vmoptions file for the VM options.

Comment actions Permalink

Thanks for the reply,

Your answer makes sense except my install directory doesn't contain:
C:\Program Files (x86)\JetBrains\IntelliJ IDEA 11.0.1\bin\idea64.exe or idea64.exe.vmoptions

Comment actions Permalink

Are you using the community edition?  I don't believe that comes with 64-bit support.

Comment actions Permalink

Yes, then that would explain it. Only why have 64-bit dll's like IdeaWin64.dll and others? That would imply it has 64-bit capabilities but maybe there just not implemented yet.

Comment actions Permalink

U can use idea64.exe from IDEA UE, or use from my issue, idea-exe-UPDATE 1.rar/idea64.exe, if had errors I'ill fix it

Comment actions Permalink

"U can use idea64.exe from IDEA UE"

What does this mean? Where can I get this?

Comment actions Permalink

Download IDEA Ultimate Edition and get it

Comment actions Permalink

On Wed, 29 Feb 2012 01:09:48 MSK, Mike Retondo
<> wrote, quoted or indirectly quoted someone
who said :

>Really, not a single reply for such a basic question, this is amazing? So I'm to assume Intellij 11 doesn't support 64-bit mode I guess. I sure would be nice if Intellij developers would read this discussion board.

Look in the bin directory. There are two executables, one for 32 bit
and one for 64. Just start the 64-bit one . Make an icon on your task
Roedy Green Canadian Mind Products
One of the most useful comments you can put in a program is
"If you change this, remember to change ?XXX? too".

Comment actions Permalink

Thanks for the help but if it's not part of the comunity edition I'll just wait. I'm just surprised that's all.

Comment actions Permalink


Full details in my blog at but short answer is to use idea.bat and configure the JDK you use to launch IDEA.



Comment actions Permalink

I gave this a try but got errors when running the idea.bat file (see below). I duplicated the idea.exe.vmoptions to idea64.exe.vmoptions. I don't hava a JAVA_HOME variable but I have a JDK_HOME. So I moved the JDK_HOME lines of code up to the top.

C:\Program Files (x86)\JetBrains\IntelliJ IDEA Community Edition 11.1.2\bin\\idea64.exe.vmoptions
Unhandled exception
Type=Segmentation error vmState=0x00000000
Windows_ExceptionCode=c0000005 J9Generic_Signal=00000004 ExceptionAddress=0000000076FECB23 ContextFlags=0010001f
Handler1=000007FFFF67D3B0 Handler2=000007FFFF64DF00
RDI=000007FFFEC70000 RSI=000007FFFEC70000 RAX=00000000FEC701F7 RBX=00000000FEC700F0
RCX=00000000FEC700F0 RDX=0000000000000108 R8=00000000FEC700F0 R9=0000000000001000
R10=0000000000000010 R11=0000000000000000 R12=0000000180000000 R13=0000000000000001
R14=00000000050ED2C0 R15=0000000000000000
RIP=0000000076FECB23 RSP=00000000050ED0F0 RBP=00000000050ED878 GS=002B
FS=0053 ES=002B DS=002B
XMM0 000000000000027f (f: 639.000000, d: 3.157079e-321)
XMM1 0000000000000000 (f: 0.000000, d: 0.000000e+000)
XMM2 0000000000000000 (f: 0.000000, d: 0.000000e+000)
XMM3 0000000000000000 (f: 0.000000, d: 0.000000e+000)
XMM4 0000000000000000 (f: 0.000000, d: 0.000000e+000)
XMM5 0000000000000000 (f: 0.000000, d: 0.000000e+000)
XMM6 0000000000000000 (f: 0.000000, d: 0.000000e+000)
XMM7 0000000000000000 (f: 0.000000, d: 0.000000e+000)
XMM8 0000000000000000 (f: 0.000000, d: 0.000000e+000)
XMM9 0000000000000000 (f: 0.000000, d: 0.000000e+000)
XMM10 0000000000000000 (f: 0.000000, d: 0.000000e+000)
XMM11 0000000000000000 (f: 0.000000, d: 0.000000e+000)
XMM12 0000000000000000 (f: 0.000000, d: 0.000000e+000)
XMM13 0000000000000000 (f: 0.000000, d: 0.000000e+000)
XMM14 0000000000000000 (f: 0.000000, d: 0.000000e+000)
XMM15 0000000000000000 (f: 0.000000, d: 0.000000e+000)
Module_base_address=0000000076FA0000 Offset_in_DLL=000000000004cb23
Target=2_40_20120202_101568 (Windows 7 6.1 build 7601 Service Pack 1)
CPU=amd64 (2 logical CPUs) (0x1faf45000 RAM)
----------- Stack Backtrace -----------
JVMDUMP039I Processing dump event "gpf", detail "" at 2012/06/22 11:56:29 - please wait.
JVMDUMP032I JVM requested System dump using 'C:\Program Files (x86)\JetBrains\IntelliJ IDEA Community Edition 11.1.2\bin\core.20120622.115629.5800.0001.dmp' in response to an event

Comment actions Permalink

Strange! Maybe it is a Win7 thing then. Can you send me your batch file - - and I will give it a try. What JDK are you using? What is your JDK_HOME set to?


Please sign in to leave a comment.