Version Control Confirmation not prompting

I'm using Idea 11 and SVN 1.7, and I when I first stated I was getting confirmation boxes for "Do you want to add the file..." and/or add silently would just do it.

However at some point, this stopped working. I'm looking in the Settings unded Version Control / Confirmation, and everything is set to "Show options". Is there another setting I'm missing?

4 comments
Comment actions Permalink

Hello Leif, sorry, I didn't understand what is happening now.
The settings you menthioned are indeed responsible for what should be done wjen new files are create in IDEA (or deleted in it).

Are the new files being added?
Do you see confirmation for addition?

Please note that confirmation (or other actions according to settings) are applicable only to files that are created using IDEA, not outside of it.

0
Comment actions Permalink

For this project, I'm on the community edition using Android.

These are my reproducable steps:

  1. Right click on /res/layout
  2. Click New/Layout resource file
  3. Name and save it
  4. I never get prompted for the new file to be added


Settings in Version Control / Confirmation:

  • When files are created: Show options...
  • Display Options: Update, Checkout


I did notice something this time around. When I first opened the settings panel, ONLY update and checkout were visible under "Display options dialog when...". However when I closed it, and re-opened the settings panel, it also showed the other options of Add, Edit, and Status, which all three are greyed out.

So it seems like something is quirky in this area. No matter what settings I change, I cannot get it to prompt me on add, and I cannot get it to add silent. Manual SVN add still works of course.
0
Comment actions Permalink

I've created a bug for file addition, will deal with it:
http://youtrack.jetbrains.com/issue/IDEA-88128

As for different contents of VCS actions, we already have a bug for that http://youtrack.jetbrains.com/issue/IDEA-58285

0
Comment actions Permalink

Checked, see my comment in issue

0

Please sign in to leave a comment.