Adobe AIR 3.2 SDK and higher, URI is not registered


i'm currently trying to use the Adobe AIR 3.2 SDK to create a mobile project with Intellj IDEA but there seems to be a problem with the namespace for the versions 3.2 and higher.
In the application descriptor the part

is marked as red and the inspector is saying the the "URI is not registered".

When i disable the inspections and try to compile i get the "error while loading initial content" which bascially means that version number at the line:

<application xmlns="">

doesn't match the SDK version.

When i use the "Create" button from IDEA for creating an Android/iOS application descriptor file it only display the versions 1.0 to 3.1 under the AIR dropdown field.

I've downloaded the AIR 3.2 and Flex SDK 4.6 from Adobe and merged them as i would do with for example 3.1.
I've also tried an already merged Flex 4.6 and AIR 3.2 SDK from but this also doesn't work.

Thinking there might be something wrong with the 3.2 SDK i've tried the new 3.3 beta but it gives me the same error.
Every SDK before 3.2 works fine for me.

I've noticed that since the AIR 3.2 SDK there is a new folder in the templates folder called sdk (templates/sdk/) which has a "Descriptor.3.2.xsd" file.
This file seems to have a regexp for exactly that line to check the version number.
Not sure if this is what is causing the trouble but i thought i mention it.

I've tried it with the sample project IDEA is creating when making a new project/module.
Settings are mobile and pure actionscript.


edit: i also tried the newest IDEA EAP 117.216


We'll add new namespaces support out of the box for the next IntelliJ IDEA update release. For now for your convenience you can map namespace to the schema from SDK (Descriptor.3.2.xsd) manually at Settings (Preferences on Mac) | Schemas and DTD. Error "error while loading initial content" is not related to file highlighting in editor.

it only display the versions 1.0 to 3.1 under the AIR dropdown field

The field is editable. And the created file itself is editable.

IntelliJ is designed to support future AIR releases. If you still have no luck with it I'll create a sample project and attach here.

Thx you for your post Alexander, you did help me with that.
I tried multiples times adding a new schema before but i didn't work, i tried it now again and it worked. Looks like i made a mistake which i didn't see, thanks.

About that error, people get the error most of the times when they forget to updated this line to the new sdk version, but in my case the error is produced by the compiler argument: -swf-version=15.
But i'm gonna fix this one myself.

Thank you again for your answer and for doing such a great job with IDEA.



I'm running into the same problem.  I have downloaded the new Air 3.3, but when trying to package for iOS I get the following problem when setting the namespace as:

Failed to package AIR application MyProject.ipa:
         myproject_ios-ios-descriptor.xml: error 102: Invalid namespace

I've tried to add the namespace manually but it does not seem to fix the issue.  I made a new 3.3.xsd descriptor and put it in the templates/sdk folder, but no luck.

Does Air 3.3 support iOS yet?


Alex, that's a different problem.
First of all please update to IntelliJ IDEA 11.1.2, it has AIR 3.2 and 3.3 schemas bundled - so you won't have highlighting problems with your descriptor file. If you now use IntelliJ IDEA 11.0 or older then pay attention that we have completely redesigned Flex project setup. See information in this blog post and in bundled help (Language and Frmeworks -Specific Guidelines | ActionScript and Flex).

Packaging errors are not related to highlighting inside IntelliJ IDEA. To package ipa file IDEA just launches adt tool from Flex SDK. So looks like you haven't unpacked donloaded AIR 3.3 SDK on top of existing Flex SDK installation.


Please sign in to leave a comment.