persistence window not available

When I open IntelliJ the persistence window is not available on the left hand bar.  When I go to View -> Tool Windows it is not available as an option.  I have not made any configuration changes and the window was there when I opened IntelliJ on Friday.  Can anyone tell me how to make it come back?

Thanks!

6 comments
Comment actions Permalink

Hi.

Persistence tool window is shown in a project frame, if some of this project's modules has Hibernate or JPA facet. Hope it helps.

Regards,
Alexander.

0
Comment actions Permalink

This decidely does NOT help.  I have references to JPA in this project.  I have not changed the references.  I have not changed any configurations.  The
window is just not there.  I need to check the persistence units and cannot because the window is not there.

0
Comment actions Permalink

Hi Eva,

if you read Alexanders reply it should help:
go to project view and check if your module has JPA facet. If not there, you can add it (right-click onto module and add JPA facet to your project)
(If there, than something else is wrong )

0
Comment actions Permalink

It appears my colleague DID change something in configuration to make the JPA reference go away and I had gotten the latest.

Being still new to IntelliJ, thank you for the basic guidance as to where to find stuff.  There are a lot of menus and links so being told how to navigate the tool, somewhat, helps a person sort of figure out where to go look for this.  The actual path to see these facets however is File -> Project Structure.  This brings up a popup window where you can click Facets in the left hand side under Project Settings.  To add a facet, click the plus icon at the top of the list of included facets.  I am including this information for anyone else who stumbles on this thread.

1
Comment actions Permalink

evaleah wrote:

It appears my colleague DID change something in configuration to make the JPA reference go away and I had gotten the latest.


this may help to avoid these issues:

http://devnet.jetbrains.net/docs/DOC-1186

cheers
/m

0
Comment actions Permalink

In addition to Sheva2's comment, if the relevant facets are not available, one should go to:

File -> Settings... -> Plugins and enable "Hibernate support", "Java EE: EJB, JPA, Servlets", etc.

0

Please sign in to leave a comment.