IntelliJ 11 Mac function keys not working

Answered

Hi All,

This is IntelliJ 11.1.1 running on a Macbook 10.6.8

When I'm debugging, the usual function keys f7, f8, f9 etc.. are not working for me.   IDEA says these are the proper key mappings.

Any ideas?

6 comments
Comment actions Permalink

I found it.

There's an option in the System preferences to allow applications to use the function keys.
Here's the link for anyone else having this issue.

http://www.bittbox.com/os-x/mac-users-a-note-on-adobe-keyboard-shortcuts

3
Comment actions Permalink

You can _use_ the function keys as function keys regardless of the setting. By default OS/X sets the primary function of the keys to whatever graphic icon is printed on them, e.g., screen brightness. You can switch to the alternate usage by holding down the 'fn' key in the lower left corner, e.g., 'fn-F1'. This is because "normal" applications in OS/X don't use function keys. But Unix applications and cross-platform applications do use them. So most people who buy and use a Mac (non-developers) will never have a need to press a function key. But people like us, who develop software, need that setting.

2
Comment actions Permalink

Hi Dan,

Sorry to butt in on this thread, but I am an old friend of yours from back in the dBASE days.

You are not an easy guy to find.

Can you email me at george@trueshot.com

George Burt

0
Comment actions Permalink

Ahh thanks. Good to know.

0
Comment actions Permalink

I'm having a similar but not same issue. When I hit F8 in debug to step over, the Run menu highlights briefly but nothing happens. This is with a regular (PC) keyboard but same results when applying the workaround (FN+F8 or sys pref to enable) above and using the built-in laptop keyboard. Any ideas on this?

0
Comment actions Permalink

I have a mac with PC keyboard (Microsoft Natural Ergonomic Keyboard 4000 v1.0). I had the same issue, but I've found that my keyboard has key "F Lock"(on the same row with F1-F12 buttons), and this key switches behaviour of "F1-F12" keys. That "F Lock" button helped in my case.

0

Please sign in to leave a comment.