Latest Demetra build don't start on Windows Vista Beta 2

Hi
I'm trying to use latest Demetra build on Windows Vista Beta 2 but it don't
start.

Egor Margineanu.


4 comments
Comment actions Permalink

Egor Margineanu schrieb:

I'm trying to use latest Demetra build on Windows Vista Beta 2 but it
don't start.


I managed to run IDEA EAP on Vista with the following two hacks. Both
JDK 1.5 and the latest Mustang builds have problems with the Vista
Seagoe font which triggers a NullPointerException in Swing. So I created
this AWT-Toolkit for Mustang

public class VToolkit extends WToolkit {
private static boolean once;
public VToolkit() {
if (!once) {
once = true;
desktopProperties.put("win.defaultGUI.font",
getDesktopProperty("win.icon.font"));
}
}
}

which must be passed as -Dawt.toolkit=VToolkit on the Java command line.
Because IDEA insists on running on JDK 1.5, I added a java.lang.System
implementation to the boot class path which modified the java.version
system property before IDEA checks it. So IDEA thinks it's still
running on JRE 1.5.

BTW, Eclipse 3.2 runs just fine with Mustang and Vista and it - compared
to IDEA with Swing's current wanna-be-Vista-look - is looking great.
However, the Swing team promised that they'll further improve the Vista
look and if they add the missing annimations, the emulation should be
close enough to the original so that you can't really see any difference
anymore. The subpixel-rendering of Swing however looks different that
the one used by WPF/Vista for the new Windows fonts. But that might be
Microsoft, who somehow modified the algorithm so that for example even
the Acrobat Reader's output looks somewhat blured and "washed" compared
the clean and crisp look for the same document in Word 2007.

--
Stefan Matthias Aust

0
Comment actions Permalink

Because IDEA insists on running on JDK 1.5, I added a
java.lang.System
implementation to the boot class path which modified
the java.version
system property before IDEA checks it. So IDEA
thinks it's still
running on JRE 1.5.


-Didea.no.jdk.check=true :)

0
Comment actions Permalink

To save the rest of us 20 min:

Take the attached jar file and put the jar file in /*lib *folder

Change your bin/idea.exe.vmoptions to include these lines (modify paths for your config)

-Xbootclasspath:c:\intellij\lib\VToolkit.jar;c:\jdk1.6\jre\lib\rt.jar
-Dawt.toolkit=VToolkit

PS: jar is compiled with jdk 1.5. If you need 1.3 compatibility, I included the .java file as well.

Thanks, Stefan! Life saver! Genya, give him a star or smth.



Attachment(s):
VToolkit.jar
VToolkit.java
0
Comment actions Permalink

I just tried this. I'm having problems running it in Vista (5472).

Before I tried the steps above, it would just show the spash screen and freeze there.

Now, the spash screen flashes and then disapears.

I've installed both
J2SE Development Kit 5.0 Update 8
J2SE Runtime Environment 5.0 Update 8

If I run the idea.bat file, I get the following error:
c:\Program Files\JetBrains\IntelliJ IDEA 5.1\bin>idea.bat
-


ERROR: cannot start IntelliJ IDEA.
No JDK found to run IDEA. Please validate either IDEA_JDK or JDK_HOME points to
valid JDK installation
-


Press any key to continue . . .
c:\Program Files\JetBrains\IntelliJ IDEA 5.1\bin>

-gk

0

Please sign in to leave a comment.