Frustration with keyboard shortcuts on Mac OS X with IntelliJ IDEA 11.1

On OS X there are so many shortcuts not working as expected, i am quite grrr... :-(

Examples:
Commenting / Uncommenting:   Cmd + /      => Opens the Help from the main menu
Comment with Block Comment:  ctrl + ? => Nothing happens
Move cursor to start or end Cmd + [ or ] => ´Nothing happens
All Shortcuts where i have to put in "[" or "]"   => nothing happens

Am I doing something wrong??

I remapped some of the most important shortcuts, but that does not make much sence when there are so many...

Btw: I have a german keyboard, maybe thats the problem???

Ingo

15 comments
Comment actions Permalink

Thank you Andriy,

so this means, there is no good solution...

0
Comment actions Permalink

I don't know for sure -- but I guess No.

I'm not a Mac user or Java guy .. but I see 2 basic workarounds here:

  1. Re-map key binding to those that will work in German keyboard layout.
  2. Have 2 keyboard layouts in your OS -- German and English: use English one when coding (so all shortcuts will work) and switch to German when typing those few German (maybe better say, not-English) characters. This is obvious and only one approach that I'm using when I need to type any Cyrillic text (Russian, Ukrainian) -- it works well because of completely different alphabets. In your case this can be difficult to use as it seems unnatural for you since you use almost the same alphabet (you can type all Latin letters when on German keyboard layout).
0
Comment actions Permalink

I created my own Intellij IDEA keyboard reference.
You can get the current PDF and the Word template to create your own at: http://victorvolle.wordpress.com/2012/05/16/intellij-german-keyboard-shortcuts-reference/

1
Comment actions Permalink

Thanks!

By the way:

By random I found that on german keyboard

//
is mapped to
cmd -

/**/
is mapped to
cmd shift -

2
Comment actions Permalink

yes, that's already documented in my keyboard reference

0
Comment actions Permalink

Hi, this hotkeys

//
is mapped to
cmd -

/**/
is mapped to
cmd shift -

Work in keyboard latin with ñ

webstrom comment block and line keyboard latin or non english

 

0
Comment actions Permalink

So, we now have 2020, 12 years since this issue was submitted, and it still isn't fixed. I have the same problem (Mac + German keyboard, but on Rider), and I'm flipping out that such a simple problem cannot/will not be fixed. JETBRAINS: DO SOMETHING ABOUT IT

2
Avatar
Arseniy Nisnevich
Comment actions Permalink

Hello everyone. There're two main reasons that cause problems with shortcuts on macOS:

1. Conflicts with OS shortcuts. As a solution, we've implemented detecting those conflicts: https://youtrack.jetbrains.com/issue/JBR-1668

You'll see a notification about conflicts on a first IDE run. Also, these conflicts are listed in "Preferences | Keymap" at the bottom.

2. National keyboards problems. There's a meta issue aggregating all sorts of issues related to the topic: https://youtrack.jetbrains.com/issue/IDEA-165950

We plan to fix many of them in the nearest months.

-2
Comment actions Permalink

The answer given by JetBrains is ridiculous... YOU ARE LOSING CUSTOMERS?

The standard comment shortcut doesn't work for German users and commenting is one of the most used actions when coding.
And stop giving poor excuses: the competition is able to solve this for German Mac users (see Sublime Text).
You manage to write awesome IDE software. Why does it take you so long to fix this trivial problem?

I will go back to the competition as long as this persists.

0
Avatar
Arseniy Nisnevich
Comment actions Permalink

Hi Johannes,

Solving national keyboard problems is still work-in-progress. Unfortunately, the conflict with German keymap you've mentioned is just a single one across dozens of others. Some fixes were already delivered in 2020.2, and we'll keep working on it. A pre-release thing that will solve many problems including the aforementioned conflict is now available in a plugin (please note that it's under development so use at your own risk).

0
Comment actions Permalink

Just having new fun with my Keyboard after updating to Mac OS 11 (Big Sur) and updating to Rubymine 2020.3.1 in one rush. (So I don't know which one to blame...)

Within Rubymine I can't type backslashes any more. 

If try to type a backslash (Alt shift 7 on German keyboard) instead some word of my code is being duplicated and placed at the cursor. I I repeat the stroke the cursor is wandering to next word and next word is placed at cursor.

haha, reminds me a bit to some vim magic, but vim plugin is off (but installed)

and if you just want to proceed with your work and can't type a "\" then this ist GRRRR...

 

In all other cases outside of Rubymine \ is working as expected so here and in any other Texteditor I tried.

 

Any Idea ? Thanks!

 

 

 

 

1
Comment actions Permalink

@Ingo Klemm

Please check top 2 comments in https://youtrack.jetbrains.com/issue/WI-57724 -- seems the same to me.

0
Comment actions Permalink

thanks, same problem, same solution. works!

saved my evening :-)

(Although checkbox "Use national layout for shortcuts", seems reasonable to be checked....)

0

Please sign in to leave a comment.