Idea + Zend Server = Small problem while debugging

I'm using Intellij Idea 11.1.1 on a MacBook Pro with PHP Plugin v117.222 and I have installed Zend Server 5.6 (Community Edition); I read your documentation on the JetBrains Blog about PhpStorm and I'm trying to enable debugging on Idea through Zend Debugger. So far I almost managed it to work, but I'm still missing something important.

I created a new server under Run -> Run/Debug Configuration -> Server -> Add with those parameters:

Host: localhost
Port: 10088 (the default Zend Server port on my computer)
Debugger: Zend Debugger

If I simply try to "run" it, it works without any glitch. But when I try to debug a simple application from Idea, it opens this URL inside my default browser:

http://localhost:10088/<project folder>/index.php?

start_debug=1&send_sess_end=1&debug_start_session=1&debug_session_id=11276&debug_port=10137&debug_host=192.168.1.100%252C127.0.0.1

And inside the browser I see this error message:

"Cannot resolve host 192.168.1.100%C127.0.0.1"

But if I change the "debug_host" parameter removing "%C127.0.0.1", it works. I simply change the URL address into:

http://localhost:10088/<project folder>/index.php?

start_debug=1&send_sess_end=1&debug_start_session=1&debug_session_id=11276&debug_port=10137&debug_host=192.168.1.100



Could you help me and tell me what I could do in order to change the "debug_host" property ?

Thank you very much and best regards

2 comments
Comment actions Permalink

Hi, Francesco,

Sorry for the delay. It is an issue with PhpStorm IP detection algorithm. Unfortunately there is no way to manually override this value. Please vote - http://youtrack.jetbrains.com/issue/WI-7465.
Though if you are using debug bookmarklets (a cross-browser replacement for Zend Toolbar, http://www.jetbrains.com/phpstorm/marklets/), it shouldn't be an issue for you. See blogpost about 'Zero-Configuration debugging' for details - http://blog.jetbrains.com/webide/2011/02/zero-configuration-debugging-with-xdebug-and-phpstorm-2-0/

Thank you for feedback!

0
Comment actions Permalink

Thank you very much for your clarification.

0

Please sign in to leave a comment.