Changing the Code Completion Popup Font

  I use a font in Intellij that is restricted to only a few font sizes and the code sense popup when you type out something in intellij uses that font at a size larger than it can handle (so I get a blank window like the image below). I can however hit ctrl+space and it does oddly show everything as it should afterwards. However, I think it's still due to the font, because it doesn't happen with any other font. Is there a way to change the font (or the font size) for only the code completion window? I know it's nowhere in the GUI options, but perhaps something in a file can manually change it.

error.png

11 comments
Comment actions Permalink

Which OS, desktop environment and L&F do you use? Please try changing the L&F.

0
Comment actions Permalink

Thanks for your reply Peter. I am currently using Windows 7 and I was using Unix line endings and UTF-8 encodings. I changed it back to windows1252 and windows line endings, but it doesn't seem to have any effect as far as I can tell (tried creating a new file with it afterwards).

Oddly though, I do not have this problem with Java, only other languages (python, lua, php, etc) and only with that font. Though I would give up being able to see code sense until i press something like ctrl+space before I would give up the font, lol :)

I would file a bug with jetbrains, but I am not sure if they would consider it one or not. I know quite a few people probably use Dina (or I think they do).

0
Comment actions Permalink

The eastiest workaround is to set Settings | Editor | Code Completion | Preselect the first suggestion to 'Always', but that would also mean you may get unwanted items chosen in autopopup when you type Space or some other keys.

The problem is that when the lookup has no preselection, we paint the font semi-transparent. Apparently your system configuration doesn't support that. Have you disabled any related Windows display settings, e.g. for performance reasons?

0
Comment actions Permalink

I checked and everything is enabled under visual settings in the control panel.

I still think it's just the font being an issue, but not sure exactly why Intellij doesn't like it as code completion works fine if I switch to Consolas or something else. Maybe the font doesn't like being semi transparent?

I can try Intellij on Linux (Kubuntu) later today and see if the Dina font is still an issue there. I'll report back after.

System specs for my pc:

Nvidia 570gtx
Intel i7 920 cpu
24gb ram
Windows 7 x64 Ultimate


There wouldnt be some way to modify one of the opensource libaries of the community Intellij (I assume the UI parts are in there) and patch it to not be transparent on my own, would it? If so, any suggestions on which file to start looking in for that?

Thanks

0
Comment actions Permalink

Could you please invoke such completion and then attach here the log (Help | Reveal log)?

0
Comment actions Permalink

Sure, it's attached below.



Attachment(s):
idea.log.zip
0
Comment actions Permalink

The logs seem to contain nothing relevant. Pity. Have you tried with other fonts/systems?

0
Comment actions Permalink

I tried it on Kubuntu 11.10 with all the same settings and font. Made no difference. Is there a way to use bitmap fonts in intellij? I've seen that eclipse is able to use them.

0
Comment actions Permalink

Eclipse uses lots of native code that allow it to access Microsoft bitmap fonts, we use plain Java which doesn't see them, sorry. You could file a feature request for that to YouTrack.

Back to the problem. So you use TrueType Dina font? It works for me in both Windows and Ubuntu (have tried only GNOME so far, will try KDE later). Is it possible for you to try it with GNOME? Do you run this natively or in a virtual machine?

0
Comment actions Permalink

I think my issue is just due what's going on here and not much I can do about it other than use a different font :(


http://youtrack.jetbrains.com/issue/IDEA-57233

0
Comment actions Permalink

Quite probable, thanks for pointing to an issue, hope you voted for it as well.

0

Please sign in to leave a comment.