JDK 1.6 Exception

I'm not sure if recent EAP upgrades (4244 currently) or the updated beta of JDK 1.6 (b85 on WinXP) are causing this, but I recently started getting the attached series of exceptions when I close the last editor tab. After the exception, it's not possible to open a file until IDEA is restarted. I usually work around the bug by always leaving at least 1 tab open.

Granted, I know that I shouldn't be running IDEA under 1.6, but it "feels" a whole lot faster (double-buffering -- I know it's an illusion, but it's a very nice illusion). Plus, this is the first reproducible problem that I've had using 1.6. I suspect that it's a JDK bug, but on the off chance that it's not, I thought I'd post it here.

--Mike

Attachment not added (general error): "idea.log.gz"

9 comments
Comment actions Permalink

This is really a JDK problem. I posted a bug to them, but it is not yet visible.
As soon as it is, I'll post a link here.

0
Comment actions Permalink

This is really a JDK problem. I posted a bug to them, but it is not
yet visible. As soon as it is, I'll post a link here.


Thanks! You guys really go out of your way to make it a pleasure to develop
in IDEA . . . even when your users do things that make it extra-difficult!

--Mike


0
Comment actions Permalink

It looks like this bug:
http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6420152
Which is probably caused by the fix to this bug:
http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6368047

Bas

Eugene Vigdorchik wrote:

This is really a JDK problem. I posted a bug to them, but it is not yet visible.
As soon as it is, I'll post a link here.

0
Comment actions Permalink

Most probably you are right, though we get 0 >= 0 exception :)

0
Comment actions Permalink

This week's release (b94) finally fixes the problem of closing the last tab
causing an exception with 0 >= 0.

--Mike


0
Comment actions Permalink

Running Demetra build 5594/Mustang Beta 2 still produces the problem reliably under Ubuntu Linux. What a pity - it feels a lot faster.

Peter

0
Comment actions Permalink

Clicking "Close all Editors" on the last tab seems to work fine as a workaround.

Peter

0
Comment actions Permalink

Running Demetra build 5594/Mustang Beta 2 still produces the problem
reliably under Ubuntu Linux. What a pity - it feels a lot faster.


Mustang Beta 2 has the problem on Windows, also. Only the latest weekly
build has the fix.

--Mike


0

Please sign in to leave a comment.