How to disable smart paste or else rebind so not the default

I know I can do CtrlAltShift+V to disable smart paste, but I'd rather it be switched so that smart paste is possible ctrl-alt-shift-v and standard ctrl-v pastes as normal without escaping quotes and other characters. I looked through the settings but must be missing where the option is to disable this smart-paste feature. TIA.

3 comments
Comment actions Permalink

IDE Settings->Keymap->Main menu->Edit->Paste/Paste simple

0
Comment actions Permalink

Ok thanks that helps a lot, but is there a way then to also bind "Smart Paste" - I looked for "smart paste" and "paste smart" in the editor key bindings but didn't see that binding. Basically, I really want to just flip the short cuts for paste simple and smart paste.

(At the very least at least now I can turn off smart paste by changing the short cut to ctrl-v to paste simple.)

0
Comment actions Permalink

It's in the same section. Note that when you're editing the Keymap you
have to go to Main menu->Edit to see "Paste" (which is what you call
"Smart Paste"?), "Paste..." and "Paste Simple". If you go to Editor
actions you only see "Paste Simple".

(By the way- for questions of this type, which don't specifically
concern the EAP programme, you're better off posting to
jetbrains.intellij.community)

R

0

Please sign in to leave a comment.