Builds 5561 and later - 100% CPU

From build 5561 onwards, including 6.0 beta, IntelliJ uses 100% of the CPU shortly after loading a project. This did not happen with earlier builds. I see that someone else also has this problem and has raised a JIRA (IDEA-8435) and has also included CPU snapshots. Like me, they are also running on Linux. I tried all the usual things - removing plugins, clearing caches etc but the problem is still there.

How widespread is this problem? Has anyone else seen this running on Windows or Mac? I assume that the CPU snapshots already attached to the JIRA are sufficient to help fix the problem?

3 comments
Comment actions Permalink

I don't know if this is related, but there must be a memory leak somewhere in build 5561.
I have a quite big project, when i open it, memory is at about 250Mo used , but it soons get out of control until the Xmx param is reached however high it is set to (tried up to 1Go).

Yesterday evening i also let IDEA open on a much smaller project (about 100 classes), and coming back this morning the Xmx (512Mo) has been reached too and IDEA just keeps popping the OOM dialog, had to shut it down.

I tried to get Memory snapshots using Out of Process YJP, but everytimes IDEA crashed during the snapshot

edit : i see the new 5569 build corrects an Memory leak, i'll see it it solves my problem and get you the result

Message was edited by:
Thibaut

0
Comment actions Permalink

We have pinned the problem and will update beta download shortly.

0
Comment actions Permalink

as promised i've tried working with my big project and there still must be a noticeable memory leak somewhere, although i can now work about 30 min before having to shutdown/restart IDEA because there's no memory available yet.
edit : with the idea memory at about 500Mo used, without doing anything (just moving the mouse cursor and lauching a GC every now and then, used memory keeps raising)

Message was edited by:
Thibaut

0

Please sign in to leave a comment.