Encoding issue on accents with a Web module and Vaadin

Dear,

I'm developing a Web application (EclipseLink, Spring, Vaadin, JPAContainer) and accents aren't well encoded when exploded WAR is deployed with IntelliJ (e.g. "é" is displayed as "é").
My Google Chrome browser coding is set to automatic + UTF-8. I've tried Tomcat 6 and 7, Jetty 7 and 8 and Resin 4 without success.

When the application is deployed with Eclipse WTP or STS everything is alright (but the IDE ;)) and it is still alright when deployed within the servlet container directly without any IDE.

Is there a parameter to set within IDEA to make accents works?

Thanks,
Chris

PS: I've tried IDEA 11.0.1 and 11.1.1.



Attachment(s):
dom.png
accent.png
1 comment
Comment actions Permalink

Things seem to be fixed.
Project re-created with IDEA 11.1.1 "New Project..." wizard, it has replaced AspectJ compiler with Java compiler in project settings (why?), JRebel Social works fine and no encoding issue anymore with Tomcat 7 (not native).

Hope it helps,
Chris

0

Please sign in to leave a comment.