Unable to start Tomcat 6.0 within IDEA 11

Before recent upgrade I have been using IDEA 10.5 with Tomcat 6.0. The options I passed to VM in Run/Debug Configuration were:

"-Dcatalina.base=D:\Tomcat 6.0" -Xmx1024m

After upgrading to IDEA 11 I've imported all the settings from  previous version and tried to start the web app, but catched the error:

Connected to the target VM, address: '127.0.0.1:53578', transport: 'socket'
java.lang.NoClassDefFoundError: "-Dcatalina/base=D:\Tomcat 6/0"
Disconnected from the target VM, address: '127.0.0.1:53578', transport: 'socket'
Exception in thread "main" Disconnected from server

The point is that all the "." had been replaced with "/" (possibly trying to resolve package paths into file system ones).
Except upgrading of IDE version nothing changed.
Why does such replacement take place?

Thanks in advance.
Regards, Vladimir.

5 comments
Comment actions Permalink

What startup script is specified on 'Startup/Connection' tab of the Tomcat run configuration?

--
Nikolay Chashnikov
Software Developer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

0
Comment actions Permalink

For both Run and Debug configurations there is the same startup script (used as default):

C:\Program Files\Java\jdk1.5.0_22\bin\java -Dcatalina.base=C:\Users\plizga\.IntelliJIdea11\system\tomcat\Unnamed_project -Dcatalina.home=D:\Tomcat 6.0 -Djava.io.tmpdir=D:\Tomcat 6.0\temp -jar D:\Tomcat 6.0\bin\bootstrap.jar start

0
Comment actions Permalink

The problem should be fixed in IDEA 11.1 released yesterday.

--
Nikolay Chashnikov
Software Developer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

0
Comment actions Permalink

Ok, I'll retest the issue after updating to 11.1.

0
Comment actions Permalink

Thanks a lot!
Now that the project is able to start I can really develop with pleasure.

0

Please sign in to leave a comment.