Gnome, IDEA and ctrl+shift hotkey

Hi,

I'm wondering at a problem with gnome hotkeys event system.

The problem:

I have ctrl+shift hotkey as key to change language.

IDEA has a lot of usefull hotkeys, that starts with ctrl+shift, for example ctrl+shift+n.

If you try to press it - nothing happens. The reason is: gnome intercept event and stop bubbling.

Could any of you solve this problem, guys?

9 comments
Comment actions Permalink

There are a few general solutions:

1) Reconfigure the Gnome key mappings
2) Switch to KDE
3) Redefine the IDEA key mappings


I don't know if Gnome is configurable w.r.t. the interfering key mappings, but KDE is.


Randall Schulz

0
Comment actions Permalink

sounds pessimistic...

0
Comment actions Permalink

Pessimistic? Why? What were you hoping for? Magic?

RRS

0
Comment actions Permalink

Well,

For example, there is one bug in firefox: when you press right mouse click, sometimes you can do not what you want to do.

Why? Because there is another event system in Gnome (not sure about another DE).

Context menu is showing when you hold mouse button, not when you release it.

Problem? Yes. Is it possible to solve it? Yes! Just install any "gestures" plugin and that's it! (You can even disable all gestures).

Since you've install it - you will get another behaviour, like on Windows: context menu will be shown only after you release the button.

Is it workarround? Yes. Did it help? Yes.

Now I have exactly the same problem with keyboard and I'm looking for people who have found some program, allowing to fix (workarround is ok) that issue.

So, I don't think it's a magic.

(p.s. sorry for my english)

0
Comment actions Permalink

Well, I don't think you're facing a bug that can be fixed. There's a fundamental conflict that is going to require something to give. If Gnome's key configurations are fixed, then you are donw to two options, redefine the IDEA bindings or switch to a cnfigurable desktop (KDE, e.g.).


Randall Schulz

0
Comment actions Permalink

You need to either change the Gnome key map or change the idea key map.

when I was using Gnome I just disabled most gnome keyboard shortcuts since I didn't use many of them.

0
Comment actions Permalink

don't think this post make sense in idea forum
it is gnome problem, not idea
for example in many programs in gnome i can't use ctrl+shift+arrow to select words

for me the best solution was to use "capslock" as language switcher
on windows i also set it to capslock and now i feel ctrl+shift very very uncomfortable

0
Comment actions Permalink

Just set layout switching to right Ctrl.

0
Comment actions Permalink

This is bug of Xorg server which very old.  https://bugs.freedesktop.org/show_bug.cgi?id=865 It was open 2004-07-14 =))))))

Patch is attached to the above page. This is is not related to IDEA at all.

Patch was successfully applied (with small changes) on my system and IDEA is working now as expected.

Thanks,
Vladimir

0

Please sign in to leave a comment.