Even typing in 5321 is painfully slow

I'm finding 5321 very difficult to use -- even typing happens at a snails pace.

Anyone else seeing this behavior?

In my case, it doesn't happen with all files, just some. It doesn't seem related to file size -- much larger files than the ones that cause problems are quite easy to edit.

11 comments
Comment actions Permalink

I guess, it all relative to apearing 'Synchronizing...' in status bar. And look like aready fixed together with slownes in file chooser, as i understand.

0
Comment actions Permalink

Hello Anders,

This may be caused by project view updating, that's known problem. Try closing
project view - does typing still slow?

-


Maxim Shafirov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

I'm finding 5321 very difficult to use -- even typing happens at a
snails pace.

Anyone else seeing this behavior?



0
Comment actions Permalink

I never have the project view open -- I have the structure view open.

0
Comment actions Permalink

Yes, I've had this problem with 5321 - the IDE regularly locks up for several seconds, even when just typing, or scrolling the editor, which can be pretty confusing. Oddly, my process monitor doesn't show particularly high processor activity when this happens. I'm not editing a large file or project, so it shouldn't be garbage collection...

0
Comment actions Permalink

Same with me -- the CPU load doesn't seem to go up significantly.

0
Comment actions Permalink

Just to make things more intersting -- the file that was painfully slow is now fine.

0
Comment actions Permalink

I find this problem very intermittent. If I use 5321 on the large project at work, it can lock up in the middle of any editing activity for up to a minute - time to get a cup of tea... although, to be fair, this usually happens when the heap usage is close to the limit.

0
Comment actions Permalink

That is not IDEA then, that's garbage collector blocking. You could:

1. Increase the initial/max heap size in idea.vmoptions
2. Turn on incremental garbage collector (-Xinc), which will incur some minor perfomance hit, but will not lockup the application. The only problem is last time I tried it on IDEA builds it failed to launch with the option turned on.

0
Comment actions Permalink

This happens even when heap usage is not close to the limit.

0
Comment actions Permalink

I turned off the automatic synchronization on IDEA window reactivation (in general options), that seem to help a lot on huge projects.

0
Comment actions Permalink

I don't really want to increase my heap beyond the 440MB Idea says it has available. Idea seems to fill it fairly quickly whatever I set it to, then garbage collects regularly.

0

Please sign in to leave a comment.