Unsolicited CVS

[Followup set to j.i.e as j.i.e.c is really quiet and doesn't appear to
sync reliably with NNTP]

Other than a quick look at the first public EAP build, I've not been
using demetra. I did spend some time last night trying build 5218 on
Linux though (a clean installation with empty config, plugins & system
dirs).

I created a new project and added a single Java module, pointing it at
an existing source tree already under CVS control, and specified CVS as
the default VCS.

I was surprised to be prompted for my ssh passphrase as soon as I opened
a source file for editing, although it was nice to immediately see
gutter marks indicating local modifications already made (I also got an
IDEA internal error that I logged). How can I switch this behaviour
off? It's fair enough when I have access to the CVS server but that
can't be assumed. I had a look for a config option but didn't spot one.

I tried opening the same project in 5201 and don't see this behaviour so
I assume it's a new feature (although it's not mentioned in the release
notes for 5218).

The real pain is that on opening the project in 5218 again IDEA
immediately prompts for my SSH password/phrase (which it ironically
doesn't need) and shows a progress bar for "Get File Content" - none of
the cancel buttons has any effect and I have to kill the process.

I guess I'm surprised not to see anyone else reporting similar issues.
Maybe it's just me?

--
Mark Scott
mark@codebrewer.com

3 comments

Mark Scott wrote:

I was surprised to be prompted for my ssh passphrase as soon as I opened
a source file for editing


Seems to be caused by pointing the IDEA module at a content root that
already contains local changes. If I check out a fresh copy of the CVS
module so that there are no local changes then I don't see the automatic
CVS actions happening.

Is the behaviour I've seen by design? It would be useful to be able to
have it configurable.

--
Mark Scott
mark@codebrewer.com

0

Mark Scott wrote:

On the off-chance that someone else overlooks the same thing...

I was surprised to be prompted for my ssh passphrase as soon as I opened
a source file for editing


I sussed that the problem was the content of the properties file my
custom launch script creates for the idea.properties.file system
property. I was using properties that probably date from IDEA 4.x (if
not 3.x) and replacing those I don't override with the ones in the
demetra file did the trick. I haven't investigated which removal or
addition made the difference.

--
Mark Scott
mark@codebrewer.com

0

I'm seeing this now too - I think as a result of falling back to an
older EAP when I found problems with the latest one. Doing this
obviously trounced my local history or something.

Basically opening a class freezes the whole ui whilst it appears to work
out the diffs for the current file using cvs. It's a real pain in the
butt as I'm on a remote link to the cvs server, and so the 'cvs log' (or
whatever it does) takes forever. And what's even worse is that the work
it's doing isn't even cached locally, so I get the same pause whenever I
open a file!

Cutting my connection to cvs doesn't help as I just get the password
dialog pop up every time. The only option seems to be disabling cvs for
the project until I'm ready to commit... :(

N.

Mark Scott wrote:

I was surprised to be prompted for my ssh passphrase as soon as I opened
a source file for editing, although it was nice to immediately see
gutter marks indicating local modifications already made (I also got an
IDEA internal error that I logged). How can I switch this behaviour
off? It's fair enough when I have access to the CVS server but that
can't be assumed. I had a look for a config option but didn't spot one.

I tried opening the same project in 5201 and don't see this behaviour so
I assume it's a new feature (although it's not mentioned in the release
notes for 5218).

0

Please sign in to leave a comment.