disabling code coverage

Hi,

When code coverage have been activated on a RUn configuration, it is impossible to deactivate it if your current JDK is not 1.5. The problem is that not all jdks support the options used to run the code coverage tool.

For example here is the output when i use a coverage enabled configuration with an IBM JDK 1.3
Unrecognized option: -javaagent:C:\Documents and Settings\E9310750\Progs\JetBrains\IntelliJ IDEA 5261\lib\emma-agent.jar= -o "C:\Documents and Settings\E9310750\.IntelliJIdea60\system\coverage\AllTests.es"
Unable to parse 1.2 format supplied options - rc=-6
Could not create the Java virtual machine.


Suggestion : when the jdk forbids using code coverage (eg not 1.5), deactivate the coverage configuration

Please sign in to leave a comment.