Ant build doesn't compile

Hi,

I've generated an ant build including the option "Enable UI forms compilation". (Idea 9.0.3)

When I run this it fails on the compile.module.xxxxx.production. It seems to be requiring the forms_rt.jar stuff for compilation.

I looked at...

http://devnet.jetbrains.net/click.jspa?searchID=466667&objectType=2&objectID=3440079

but this seems to be post compile problems.

I noticed that the <taskdef name="javac2" and name="instrumentIdeaExtensions" are marked as missing even though they seem to exist...

<property name="javac2.home" value="${idea.home}/lib"/>
  <path id="javac2.classpath">
    <pathelement location="${javac2.home}/javac2.jar"/>
    <pathelement location="${javac2.home}/jdom.jar"/>
    <pathelement location="${javac2.home}/asm.jar"/>
    <pathelement location="${javac2.home}/asm-commons.jar"/>
    <pathelement location="${javac2.home}/jgoodies-forms.jar"/>
  </path>
  <taskdef name="javac2" classname="com.intellij.ant.Javac2" classpathref="javac2.classpath"/>
  <taskdef name="instrumentIdeaExtensions" classname="com.intellij.ant.InstrumentIdeaExtensions" classpathref="javac2.classpath"/>
  

... yet the javac2 process runs fine.

I can't unpack the forms_rt.jar into the ...\out\production\... folder as the clean operation removes everything first although I can add this afterwards for the deployable jar.

I've done this before without problem, but can't see the difference between the one that works and this one.

Thanks for assistance in advance.

Mark.

Please sign in to leave a comment.