Column Mode Editing?

I just started using Intellij for class, and so far, I LOVE it. It's fantastic compared to Eclipse. But there's been something bugging me since the day I've started using it. I've searched high and low and can't find an answer. Mostly because I don't know what it would even be called.

My problem is that there's 'infinite' white space after any line in the editor. If I have this text:

{
System.out.println("Foobar"); [Cursor is here]
}

And I press down on the keyboard, in any other editor, the cursor would end up just after the closing bracket. But in IntelliJ, I end up 30 characters out on that line, as if there were 30 spaces there, but there clearly isn't. This is a HUGE problem, as I simply can't get used to it, and I don't want to. If anybody could help me out, I would really appreciate it.

2 comments
Comment actions Permalink

Hi Gordon,

Please untick Settings | Editor | Allow placement of caret after end of line

P.S.
You can use search box in Settings screen to quickly find all possible options for a specific keyword (e.g. caret) and check their settings one by one until you find correct one.

0
Comment actions Permalink

Which should really by OFF by default:
As Gordon pointed out most every other editor behaves differently, so people are used to it.
Plus I don't see any advantage with being able to move behind the line end.
In fact this issue comes up in the forum again and again.

On 16.02.2012 05:29, Andriy Bazanov wrote:

Hi Gordon,

>

Please untick Settings | Editor | Allow placement of caret after end of line

>

---
Original message URL: http://devnet.jetbrains.net/message/5451886#5451886


0

Please sign in to leave a comment.