Flex mobile: slow startup/loading for iOS

Hi!

If I package my app for testing it starts up nice with only a couple of seconds.
But if I package it for ad hoc or for app store it takes over 30 seconds to start up! After that it runs fine.

I can't figure out what is wrong here since the only thing I'm changing is how i package the app.

Any ideas?

I'm using IntelliJ 10.5 and Flex sdk 4.6 with the 3.1 AIR runtime.

I created a simple app with only one button and it takes over 20 seconds to start.
When I create a new project in Flash CS5 it only takes 3-4 seconds to start.

5 comments
Comment actions Permalink

Also.. I tested with Flash Builder 4.6 and it works perfectly. 2-3 seconds to start up.

Anybody else seen this? Is it something I can do to change it or is it a bug?
Is this fixed in 11? I would love to have an excuse to upgrade! ;)

No way I'm changing to Flash Builder, but it's a hassle to copy all my code for every release :) Would really like a fix for this!

0
Comment actions Permalink

IntelliJ IDEA uses packaging tool from Adobe's Flex SDK, I believe Flash Builder uses the same packaging mechanism. That's rather strange that different types of packagings give so different startup performance. Can you please attach sample project to test on our device? (Don't include personal files like provisioning profile and certificate)

0
Comment actions Permalink

I know! It's totally wierd..

The example I was testing with is just a couple lines of code. Ziped it and attached it. Let me know if there's anything else you need to know about my settings or whatever!

I tested it on iPhone 3gs, but I know that it doesn't make a difference what device I'm packaging to.



Attachment(s):
test.zip
0
Comment actions Permalink

Thank you! I've reproduced the issue.
When Flash Builder exports release build it compiles SWF without debugging info. But in IDEA workflow is a bit different and when IDEA packages *.ipa it takes already compiled SWF. And by default compiled SWF contains debugging info. Indeed, ad hoc applications starts very slowly if underlying SWF contains debugging info.
So you need to compile non debuggable SWF in IDEA. To do this you need either uncheck corresponding check box at Settings | Compiler | Flex Compiler (there are project level settings) or to add -debug=false as additional compiler options for particular Flex module (additional options override project level options). *.ipa package based on non-debuggable SWF will start fast.

0
Comment actions Permalink

Thanks so much!! That fixed the problem! Happy to see it was that easy to fix.

Same test app starts in 4 seconds insted of 20 :D

Stupid setting I didn't know about... ;)

0

Please sign in to leave a comment.