Path Variabes in build/deploy setting

I've defined a path variable DEPLOY_FOLDER using the path variables in the
settings panel.

Now for my web module, I want to use that folder to specify where the war
file is going to be deployed to but I must not be getting the syntax quite
right. What I have is:

$DEPLOY_FOLDER$\mywar.war

But that doesn't seem to work. Anyone have any ideas?

Thanks!
Grant Gochnauer
http://www.gochnauer.org


2 comments

Anyone have any idea about doing this?

"Grant Gochnauer" <grant@gochnauer.org> wrote in message
news:e10sl7$t3$1@is.intellij.net...

I've defined a path variable DEPLOY_FOLDER using the path variables in the
settings panel.

>

Now for my web module, I want to use that folder to specify where the war
file is going to be deployed to but I must not be getting the syntax quite
right. What I have is:

>

$DEPLOY_FOLDER$\mywar.war

>

But that doesn't seem to work. Anyone have any ideas?

>

Thanks!
Grant Gochnauer
http://www.gochnauer.org



0

Hi Grant,

GG> Anyone have any idea about doing this?

As far as I know the path variables are not to be used directly. Instead,
IDEA replaces sections in the paths it operates with with the variables you
defined (if it finds a match) when it saves the settings to its files.

So, if you define your path variable like that and you point to your deploy
path normally (by specifying the hole file system path), IDEA should save
the path as $DEPLOY_FOLDER$\mywar.war in the module file. And when it reloads
the settings the paths will be transfomed into full paths again (potentially
to a different full path if another user has a different value for the path
variable).

HTH,
Andrei

GG>
GG> "Grant Gochnauer" <grant@gochnauer.org> wrote in message
GG> news:e10sl7$t3$1@is.intellij.net...
GG>
>> I've defined a path variable DEPLOY_FOLDER using the path variables
>> in the settings panel.
>>
>> Now for my web module, I want to use that folder to specify where the
>> war file is going to be deployed to but I must not be getting the
>> syntax quite right. What I have is:
>>
>> $DEPLOY_FOLDER$\mywar.war
>>
>> But that doesn't seem to work. Anyone have any ideas?
>>
>> Thanks!
>> Grant Gochnauer
>> http://www.gochnauer.org


0

Please sign in to leave a comment.