Cannot merge one branch from another

I have the following setup in SVN 1.6:

  • Branch1 created from trunk
  • Branch2 created from Branch1


When I try to bring Branch2 up-to-date by merging changes from Branch1, IDEA gives me the error message:

You are going to reintegrate changes.
This will make https://foo.com/local/foo/branches/Branch1 no longer usable for further work.
Are you sure?

I click "Cancel" since am most definitely not reintegrating a branch; development needs to proceed on both Branch1 and Branch2. I am clicking "Merge from..." on the "Subversion Working Copies information" tab to perform this merge.

This works successfully when I bring Branch1 up-to-date by merging changes from the trunk. I can also bring Branch2 up-to-date by merging changes from Branch1 successfully with TortoiseSVN or the svn command line.

Any idea why I cannot merge changes from Branch1 to Branch2 within IDEA?

I am running IDEA Ultimate 10.5.2.

Thanks.

5 comments
Avatar
Irina Chernushina
Comment actions Permalink

Hello Chris, we will test the situation you described.

It was some time ago that I dealt with "Merge from" functionality, so I'm not sure in this concrete case (that I tried it)

According to the description you gave - about the branches structure - it all should just merge changes, and, indeed, it is NOT a reintegration

0
Comment actions Permalink

I have upgraded to IDEA 111.69 and still see the same problem. Here are some additional steps that might help reproduce the problem.

  1. Create branch1 from the trunk.
  2. Make some changes in both the trunk and branch1.
  3. Merge changes from trunk to branch1.
  4. Make changes in branch1.
  5. Create branch2 from branch1.
  6. Make changes in both branch1 and trunk.
  7. Merge changes from trunk to branch1.
  8. Merge changes from branch1 to branch2.


Step 8 is where I get the error in IDEA and have to revert to using the command line or TortoiseSVN.

Thanks.

0
Comment actions Permalink

One more bit of information. The error happens with ideaIU-111.123, but not with ideaIC-111.123.

I built and ran ideaIC-111.123 under debug and it works correctly.

0
Comment actions Permalink

This problem was solved when I deleted the .IntelliJIdea11/system/vcs and .IntelliJIdea11/system/vcsCache directories and let IDEA rebuild them.

0
Comment actions Permalink

Hi Chris,

I've submitted corresponding ticket - IDEA-81096.

Regards, Denis

0

Please sign in to leave a comment.