5181 - Inline Rename needs to support ENTER key

Since I am used to hitting ENTER to close the rename refactoring dialog,
the inline rename should also support ENTER.

It is a pain to have to hit ESCAPE to finish the operation.

7 comments

ENTER finishes the refactoring, please check once more.

0

Eugene, does inline support the HOME/END key to unselect and jump to the
start/end of the entry? Last time I tried, it didn't.

Tom

0

ENTER just inserts a newline for me.
See attached.
My ENTER looks like it is bound correctly in the KeyMap.



Attachment(s):
5181_inline_rename_step1.png
5181_inline_rename_step2.png
5181_inline_rename_step3_press_ENTER.png
5181_ENTER_KeyMap.png
0

I looked into this some more and found out..

If I uninstalled all my plugins, that didn't help.

If I did a new install of 5181 without importing my old settings, then Rename
did accept the ENTER key.

Apparantly, some of the new keybindings were not added to my keymap.
See attached difference for ENTER key.
I'm not sure why this is working for others and not me. I usually upgrade
to the latest EAP when it comes out, so my config has probably been upgraded
100 times from 4.0 to now.

Now, I am wondering if other things are wrong in my keymap.



Attachment(s):
5181_new_install_ENTER_keymap.png
5181_upgraded_install_ENTER_keymap.png
0

Here is my keymap xml file. My keymap is based on "Emacs" keymap parent.
I switched my keymap to "default" and ENTER worked in Rename. I think switched to "Emacs" and ENTER worked. It only doesn't work on my keymap.

With my Keymap "Emacs modified" Describe Key says:

Assigned to


With default or Emacs keymap, DescribeKey says:

Assigned to




Can you take a look at my keymap file and see if there is a problem?
Otherwise, I guess I can try recreating my keymap again from scratch.



Attachment(s):
Emacs modified.xml
0

I tried adding the missing keymappings for ENTER




So that my mappings for ENTER now look the same as when I
switch to default keymap or Emacs keymap, but that still didn't work.

So, I started over by maknig a new copy of the Emacs keymap,
and then making all of my changes again.

Still don't know why it wasn't working, but at least now the Inline Rename
works nice!

0

Please sign in to leave a comment.