Intellij randomly crashes

Answered

Hello,

My Intellij IDEA randomly crashes and get an EXCEPTION_ACCESS_VIOLATION. I had this issue with version 10.x and now also with 11.x.
I have attached the error log. Hope that somebody can help me, because it drives me crazy :)

Cheers,
Roberto



Attachment(s):
hs_err_pid6964.log.zip
9 comments

I have exactly the same problem. It started happening on monday on a 10.5.4 ultimate. Now I switched to 11.0.1 to see if it would make a difference, but it didn't.

My config is different though: I have linux (ubuntu 11.04) and am using a 64-bit jdk (java jdk 1.6_30, but 1.6_26 also gave me problems).



Attachment(s):
hs_err_pid23213.log.zip
hs_err_pid23434.log.zip
hs_err_pid27446.log.zip
0

The crashes have become so bad I can't load my workspace anymore... It just crashes while indexing....

0

I had a couple of IDEA crashes while debugging using Java 1.6.0_30.
Downgrading to 1.6.0_27 solved the problem (I could not check 28 and 29).

Tom

0

Please try running IDEA under a 32-bit JVM instead. With the -Xmx value that you are using, there is no benefit in running a 64-bit JVM.

0

In your case, the crash actually happens inside Windows 7 code, not in IntelliJ IDEA and not even JDK. It might be caused by hardware problems or by some third-party low-level utility that you're running (an antivirus, for example).

0

Thnx for the anwsers. I am actually using version 1.6.0_27 and I have a  32-bit JVM installed.. I guess I have to reinstall Windows ;)

Roberto

0

I've tried the following things to no avail so far:

  • Run an older kernel
  • Turn off compiz
  • Sun JDK 1.6_30 64-bit
  • Sun JDK 1.7_02 64-bit
  • Sun JDK 1.6_26 64-bit
  • Sun JDK 1.6_30 32-bit
  • OpenJDK 1.6 (latest)
  • Turn off Subversion Integration plugin (as suggested in other thread)
  • Create new user account and copy everything there.
  • Various vmparameters (found some variables in older threads that contained workaround for known java issues)
  • IntelliJ 10.5.4
  • IntelliJ 11.0.1


Note that I'm using IvyIDEA. Perhaps there might be a problem there? Though I really need that plugin.

Also, the 32-bit jdk seemed to crash faster than the 64-bit variant.

0

Is there any solution for this problem? Its crashing my IDE repeatedly. The only thing helping is to turn off indexing.

0

@Thomas Zimmer please file an issue at https://youtrack.jetbrains.com/issues/IDEA and attach java crash log (files with names like `java_error_in_idea_*.log` in your user home directory) and IDE log folder zipped.

0

Please sign in to leave a comment.