Import in JSPs still not working

Occasionally on JSP pages when you use a new class Intellij prefixes the package path before the class name. This is not what you want. Never seems to do it for java classes, only JSP pages. For the rest JSPs work fine. This is pointed out in two bugs:

http://youtrack.jetbrains.net/issue/IDEA-60351

http://youtrack.jetbrains.net/issue/IDEA-59716

This broke sometime in release 9: it is only fixed in 9.02 (in version 8 it always worked and still does), and is broken again in all successive versions (e.g. 9.0.4 and following), whethern on Windows or on OSx.

In version 11, not only the bug is still there, but if you remove all imports, the "magic" auto import creation features imports them all wrong (with full path in the body) apart from the first one, which is placed all alone at the top of the page.

6 comments
Comment actions Permalink

It's not reproducible for me in Nika. Could you attach a simple project to
reproduce?
BTW have you any third-party plugins installed?

"Pietro Polsinelli" <no_reply@jetbrains.com> сообщил(а) в новостях
следующее:21794794.66941327326872347.JavaMail.devnet@confluence.jetbrains.net...

Occasionally on JSP pages when you use a new class Intellij prefixes the
package path before the class name. This is not what you want. Never seems
to do it for java classes, only JSP pages. For the rest JSPs work fine.
This is pointed out in two bugs:

>

http://youtrack.jetbrains.net/issue/IDEA-60351

>

http://youtrack.jetbrains.net/issue/IDEA-59716

>

This broke sometime in release 9: it is only fixed in 9.02 (in version 8
it always worked and still does), and is broken again in +all successive
versions+ (e.g. 9.0.4 and following), whethern on Windows or on OSx.

>

In version 11, not only the bug is still there, but if you remove all
imports, the "magic" auto import creation features imports them all wrong
(with full path in the body) apart from the first one, which is placed all
alone at the top of the page.

>

---
Original message URL: http://devnet.jetbrains.net/message/5449818#5449818


0
Comment actions Permalink

No external plugins. The problem appears also in the simple project attached (Intellij 11.0.1).



Attachment(s):
meltinPlot.zip
0
Comment actions Permalink

Thanks Pietro, I can reproduce it now.
The bug appears if you have "Project Settings / Code Style / Java / Imports
/ JSP imports layout / Prefer comma separated import list" option set.
Could you submit a YouTrack ticket for this?

"Pietro Polsinelli" <no_reply@jetbrains.com> сообщил(а) в новостях
следующее:31546005.70271327335678343.JavaMail.devnet@confluence.jetbrains.net...

No external plugins. The problem appears also in the simple project
attached (Intellij 11.0.1).

>

---
Original message URL: http://devnet.jetbrains.net/message/5449848#5449848


0
Comment actions Permalink

Done: http://youtrack.jetbrains.net/issue/IDEA-80313 - though it strangely immediately got marked as "out of date"

0
Comment actions Permalink

What got marked as out of date? What do you mean by that?

0

Please sign in to leave a comment.