Tomcat Configuration With Intellij 11

Dear All,

I am a lisenced user of Intellij. Currently our company has switched from MyEclipse to Intellij. I recently configured tomcat 7
with intellij 11. When i have run the application and try to find the deployment inside my local tomcat installation. I am unable
to find it. After googling, i found out may be, intellij is using its on CATALINA_BASE. I tried putting an environment variable CATALINA_BASE
and pointed it towards my own local tomcat directory but still no use. My deployed application remains un-disconverable. Please help and
suggest the work-around.

BR,
Ben

4 comments

IDEA changes CATALINA_BASE environment variable to deploy artifacts to Tomcat without copying to /webapps folder. If your artifact is specified on
'Deployment' tab of the Tomcat run configuration it should be deployed when the run configuration is started.

--
Nikolay Chashnikov
Software Developer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

0

Dear Nik,

Thanks for your prompt turn-around. The fact is it does get deployed and the application also loads up but i want the application

to be copied(A.K.A) deployed to tomcat webapps folder. Can i do it somehow? Your pointers will be highly valuable.

Thanks,

Ben

0

You can change 'Output directory' path in the artifact editor in 'Project Structure' dialog to point to webapps folder. But why do you need this? It
is recommended to use the default settings when you start Tomcat from IDEA, in that case /webapps directory won't be polluted and Tomcat will start
faster because it will deploy only your application. In order to start your application on Tomcat without IDEA you can create a separate war artifact,
change its output directory to webapps folder and build that artifact (using Build | 'Build Artifacts' action) only when necessary.

--
Nikolay Chashnikov
Software Developer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

0

Thanks Nik. It was a really a helpful answer and valuable feedback for me.

Thanks,
Ben

0

Please sign in to leave a comment.