How to enable i18n support ?

I'm using 5.1 on WinXP.
I've installed it on 2 machines(work and home).
On both machines i work on the same project.
This project has 6 messages.properties (for 6 languages).
On my work machine i18n-support is working.
(i can see the values of a property with 'quick documentation lookup')
But on my home machine it doesn't work.
I also see the following differences:
On my work-machine i have externalization settings (in project tab of
settings), i have I18n settings in the error tab and i have an
PropertiesEditor Plugin.
These all i don't have on my home machine !
And i don't find the PropertiesEditor-Plugin in the list of available
plugins.

So how to enable the i18n support on my home machine ?

mfg
Carsten Schäfer

8 comments

Hello Carsten,

You should not have PropertiesEditor plugin installed since this functionality
is now in IDEA core.
Please remove it and make sure .properties extension in mapped to Properties
file type (Settings|File Types).

-


Maxim Shafirov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

I'm using 5.1 on WinXP.
I've installed it on 2 machines(work and home).
On both machines i work on the same project.
This project has 6 messages.properties (for 6 languages).
On my work machine i18n-support is working.
(i can see the values of a property with 'quick documentation lookup')
But on my home machine it doesn't work.
I also see the following differences:
On my work-machine i have externalization settings (in project tab of
settings), i have I18n settings in the error tab and i have an
PropertiesEditor Plugin.
These all i don't have on my home machine !
And i don't find the PropertiesEditor-Plugin in the list of available
plugins.
So how to enable the i18n support on my home machine ?

mfg
Carsten Schäfer



0

???
PropertiesEditor plugin is on my work-machine where i18n support seeems
to work!
Here at home i don't have the plugin and i don't see any i18n support,
although properties extensions is correct assigned.

Carsten

Maxim Shafirov (JetBrains) schrieb:

Hello Carsten,

You should not have PropertiesEditor plugin installed since this
functionality is now in IDEA core.
Please remove it and make sure .properties extension in mapped to
Properties file type (Settings|File Types).

------------------
Maxim Shafirov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

>> I'm using 5.1 on WinXP.
>> I've installed it on 2 machines(work and home).
>> On both machines i work on the same project.
>> This project has 6 messages.properties (for 6 languages).
>> On my work machine i18n-support is working.
>> (i can see the values of a property with 'quick documentation lookup')
>> But on my home machine it doesn't work.
>> I also see the following differences:
>> On my work-machine i have externalization settings (in project tab of
>> settings), i have I18n settings in the error tab and i have an
>> PropertiesEditor Plugin.
>> These all i don't have on my home machine !
>> And i don't find the PropertiesEditor-Plugin in the list of available
>> plugins.
>> So how to enable the i18n support on my home machine ?
>>
>> mfg
>> Carsten Schäfer


0

I removed PropertiesEditor Plugin on my work machine and now i don't see
any i18n support on this machine as well.
This was a very good idea :(

We use a static class Messages with a method getString().
(Messages.getString("AE_APos.6"))
With the plugin installed i got a popup with all translations when i
invoke 'quick documentation lookup'
How can i enable this behavior without the plugin ?

Carsten


Maxim Shafirov (JetBrains) schrieb:

Hello Carsten,

You should not have PropertiesEditor plugin installed since this
functionality is now in IDEA core.
Please remove it and make sure .properties extension in mapped to
Properties file type (Settings|File Types).

------------------
Maxim Shafirov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

>> I'm using 5.1 on WinXP.
>> I've installed it on 2 machines(work and home).
>> On both machines i work on the same project.
>> This project has 6 messages.properties (for 6 languages).
>> On my work machine i18n-support is working.
>> (i can see the values of a property with 'quick documentation lookup')
>> But on my home machine it doesn't work.
>> I also see the following differences:
>> On my work-machine i have externalization settings (in project tab of
>> settings), i have I18n settings in the error tab and i have an
>> PropertiesEditor Plugin.
>> These all i don't have on my home machine !
>> And i don't find the PropertiesEditor-Plugin in the list of available
>> plugins.
>> So how to enable the i18n support on my home machine ?
>>
>> mfg
>> Carsten Schäfer


0

Dmitry Kashin schrieb:

CtrlShiftI ?


This is working, but not very good.
It first always shows me a language i don'understand, is the
propertyfile chosen by random ? How can i configure it to first show
messages.properties (without language extension) ?

The old behaviour was much better, it showed me all property-values at a
glance.


Carsten

0

I activated the 'Hard coded String' inspection.
Now IDEA shows me warnings about every string in my code even though i
have a NON-NLS in the line. (protected static String S_CMD_START = "net
start "; //$NON-NLS-1$)

Is this a bug ?

Carsten


Maxim Shafirov (JetBrains) schrieb:

Hello Carsten,

You should not have PropertiesEditor plugin installed since this
functionality is now in IDEA core.
Please remove it and make sure .properties extension in mapped to
Properties file type (Settings|File Types).

------------------
Maxim Shafirov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

>> I'm using 5.1 on WinXP.
>> I've installed it on 2 machines(work and home).
>> On both machines i work on the same project.
>> This project has 6 messages.properties (for 6 languages).
>> On my work machine i18n-support is working.
>> (i can see the values of a property with 'quick documentation lookup')
>> But on my home machine it doesn't work.
>> I also see the following differences:
>> On my work-machine i have externalization settings (in project tab of
>> settings), i have I18n settings in the error tab and i have an
>> PropertiesEditor Plugin.
>> These all i don't have on my home machine !
>> And i don't find the PropertiesEditor-Plugin in the list of available
>> plugins.
>> So how to enable the i18n support on my home machine ?
>>
>> mfg
>> Carsten Schäfer


0

I know :) But PE not supported cause it waste of time. May be JB will implement it or I will create micro plugin as PE missed features replacement but it very doubtful.

Thanks,
Dmitry

0

Hello Carsten,

I have created a small demo on how to enable (and use) i18n support in IntelliJ
IDEA.
See http://www.jetbrains.com/idea/training/demos/i18n.html

I hope, it can be helpful.


Best regards,
Alexandra Rusina
-


JetBrains, Inc
http://www.intellij.com
"Develop with pleasure!"

I'm using 5.1 on WinXP.
I've installed it on 2 machines(work and home).
On both machines i work on the same project.
This project has 6 messages.properties (for 6 languages).
On my work machine i18n-support is working.
(i can see the values of a property with 'quick documentation lookup')
But on my home machine it doesn't work.
I also see the following differences:
On my work-machine i have externalization settings (in project tab of
settings), i have I18n settings in the error tab and i have an
PropertiesEditor Plugin.
These all i don't have on my home machine !
And i don't find the PropertiesEditor-Plugin in the list of available
plugins.
So how to enable the i18n support on my home machine ?

mfg
Carsten Schäfer



0

Please sign in to leave a comment.