How to stop this message: "Member has protected access, but class has magic method __get"?

Answered

How to stop this message: "Member has protected access, but class has magic method __get"?

I searched everywhere but can not find the option to disable this inspection.

I really do not want the properties remain marked with a different color when they are private and there is a magic method __get in classes.

This is pissing me off.

4 comments
Comment actions Permalink

You can run Code > Inspect Code > File > right click a line in inspection results > Disable inspection.

-5
Comment actions Permalink

There's no way to disable this inspection.

To remove the mark should do the following:

  1. Settings (CTRL + Alt + S)
  2. Editor -> Colors & Fonts -> Copy the current Scheme
  3. Editor -> Colors & Fonts -> General -> Erros and Warnings -> Warning
  4. Mark off "Background" and "Error stripe mark" or do as you wish.

PhpStorm version 2016.1.2

-2
Comment actions Permalink

Dmitry's suggestion didn't help: https://i.imgur.com/TzayxcV.png

Any other tips?

0
Comment actions Permalink

As it's not a separate inspection, you can't disable it not affecting other inspections.
Please leave your vote here: https://youtrack.jetbrains.com/issue/WI-25253

0

Please sign in to leave a comment.