INtelliJ stops running progams

IntelliJ just stopped running programs. It would show a message that
the compile went ok, then stop without any error message.  I
discovered that clicking resume for programs that would not run got
them going again.  I don't know what I did that would have put them
into hibernation.
--
Roedy Green Canadian Mind Products
http://mindprod.com
I can't come to bed just yet. Somebody is wrong on the Internet.

5 comments

Maybe you should provide a little bit more details - e.g. your IDEA version,
your operating system.

Tom

0

On Sat, 19 Nov 2011 13:22:27 +0100, Tom <noname@jetbrains.com> wrote,
quoted or indirectly quoted someone who said :

>Maybe you should provide a little bit more details - e.g. your IDEA version,
>your operating system.

I was wondering if anyone else was having this problem or if there was
some button I was hitting to request this strange behaviour. I still
have not eliminated it entirely.

I am using Windows 7 64 bit IntelliJ Ultimate 10.5.2

One hypothesis I need to track down. Maybe programs are running. It is
just hiding the console.
--
Roedy Green Canadian Mind Products
http://mindprod.com
I can't come to bed just yet. Somebody is wrong on the Internet.

0

On Sat, 19 Nov 2011 01:44:47 -0800, Roedy Green
<see_website@mindprod.com.invalid> wrote, quoted or indirectly quoted
someone who said :

>IntelliJ just stopped running programs. It would show a message that
>the compile went ok, then stop without any error message.  I
>discovered that clicking resume for programs that would not run got
>them going again.  I don't know what I did that would have put them
>into hibernation.

I have figured out what is happening.  Whether I ask to run or debug,
IntelliJ is now always running debug.  I then have to hit RESUME to
kick it off.

Restarting IntelliJ does not clear this.
--
Roedy Green Canadian Mind Products
http://mindprod.com
I can't come to bed just yet. Somebody is wrong on the Internet.

0

On Sat, 19 Nov 2011 01:44:47 -0800, Roedy Green
<see_website@mindprod.com.invalid> wrote, quoted or indirectly quoted
someone who said :

>IntelliJ just stopped running programs. It would show a message that
>the compile went ok, then stop without any error message.  I
>discovered that clicking resume for programs that would not run got
>them going again.  I don't know what I did that would have put them
>into hibernation.

In an attempt to get rid of this, I uninstalled IntelliJ, wiped all
related files, and reinstalled.  Then I imported by old settings.

The problem is back. So presumably it is some setting that is causing
the trouble.  Is there any setting that would stop programs from
running, or treating runs as debugs?
--
Roedy Green Canadian Mind Products
http://mindprod.com
Premature optimization is the root of all evil.
~ Donald Ervin Knuth 1938-01-10
Unfortunately, some have misread this quotation as optimisation is
in itself evil, or even that is it wicked to consider speed when
choosing an algorithm. I counter, it is less work to do it right
the first time. Knuth was referring to clarity-destroying
micro-optimisation, now authomatically handled by optimising
static compilers and HotSpot runtimes.

0

On Sat, 26 Nov 2011 03:14:03 -0800, Roedy Green
<see_website@mindprod.com.invalid> wrote, quoted or indirectly quoted
someone who said :

>In an attempt to get rid of this, I uninstalled IntelliJ, wiped all
>related files, and reinstalled.  Then I imported by old settings.
>
>The problem is back. So presumably it is some setting that is causing
>the trouble.  Is there any setting that would stop programs from
>running, or treating runs as debugs?

I went through every setting. I removed anything I did not strictly
need. I told it never to hot swap.  When I was done RUN worked again.
--
Roedy Green Canadian Mind Products
http://mindprod.com
For me, the appeal of computer programming is that
even though I am quite a klutz,
I can still produce something, in a sense
perfect, because the computer gives me as many
chances as I please to get it right.

0

Please sign in to leave a comment.