IDEA cannot deploy to JBoss 6

I can't deploy my JEE application to JBoss 6. The application is packaged to .war file. It was working before, but now it doesn't. I have JBoss plugin, which runs JBoss and makes the deploy, but the deploy never ends.

In JBoss output I can see "Artifact is being deployed, please wait...", then there are some regular log entries, and the last meaningful is:


22:57:45,078 DEBUG [org.jboss.aop.asintegration.jboss5.AOPClassLoaderDeployer] Adding AspectManager attachment org.jboss.aop.asintegration.jboss5.ScopedVFSClassLoaderDomain@3609cce9 for AbstractVFSDeploymentContext@1030484150{vfs:///home/amorfis/workspace/idea/my-project/my-module/target/war/my-app.war}


Then there is only

22:58:21,546 DEBUG [org.jboss.modcluster.ModClusterService] Check status for engine [jboss.web] every 10 seconds or so.

Funny thing is, deployment is finished when I stop the server. When I press this red square, I have to wait quite a long time (definitely longer than regular server stop), and I can see all the logs in the output, with this at the end:


23:04:52,576 DEBUG [org.jboss.deployers.plugins.deployers.DeployersImpl] Fully Deployed vfs:///home/amorfis/workspace/idea/my-project/my-module/target/war/my-app.war
23:04:52,579 DEBUG [org.jboss.deployment.MainDeployer] isDeployed, url=vfs:///home/amorfis/workspace/idea/my-project/my-module/target/war/my-app.war, state=DEPLOYED
[2011-11-14 11:04:52,580] Artifact my-app:war exploded: Artifact is deployed successfully


System: Ubuntu 11.10 64bit
JBoss: 6.0.0.Final (Tried also with 6.1.0.Final with the same effect)
IDEA: 10.5.1

P.S. I'm able to deploy application manually (by copying .war file to the server's deploy directory) without any problems.

Best Regards
Paweł Stawicki

9 comments

Hello,

It looks like an issue specific to your server configuration, since the deploy request is sent by IDEA ("Artifact is being deployed, please wait..."), but server doesn't process the request for some reason.

In order to resolve the problem, I need an additional info:
- server log (<JBoss home>/server/<server instance>/log/serverl.log)
- complete console output (content of the 'Output' part of the Run tool window)
- idea log (<user home>/.IntelliJIdea10/system/log/idea.log)


I would also recommend to try with IDEA 11 EAP and check if the issue is reproduced with it?

The best option for me would be if you send me complete server instance folder (<JBoss home>/server/<server instance>).



Regards,
Michael
0

Thanks for your help. I'll gladly send you all the details after coming back from Devoxx :)

0

Logs attached. Tried with IDEA 11 EAP, but no success there.

What I did:
1. Run IDEA
2. Run application
3. JBoss startup, hanging on deploy on 22:10
4. Around 22:14 I stopped the process by the red square button
5. Deploy completed, jboss shutdown

Best regards
Paweł Stawicki



Attachment(s):
logs.zip
0

Logs as requested.

1. I started IDEA 11 EAP
2. I tried to run application. It tried to deploy, and hanged (around 22:10)
3. I clicked the square red button around 22:14
4. App deployed and server shutdown

Best regards



Attachment(s):
logs.zip
0

Michael, can you tell me what actually IDEA is doing when deploying app to JBoss 6? Maybe I'll be able to reproduce it outside of IDEA, and then ask for help on JBoss forum.

This issue is really painful :(

0
Pawel,


IDEA utilizes JMX protocol to manage running JBoss instance in the way, similar to described at http://www.tikalk.com/java/forums/jmx-connection-jboss

Unfortunately, from the ogs I only see that IDEA works exactly as expected, and that the problem is probably in your artifact code.

In particular, I can see that IDEA sends request for depoyment just after server startup and that the server receives this request:


(
JBoss instance is fully started: 22:10:26,218 INFO
[org.jboss.bootstrap.impl.base.server.AbstractServer] JBossAS
[6.0.0.Final "Neo"] Started in 26s:607ms
22:10:26,220 DEBUG
[org.jboss.bootstrap.impl.as.lifecycle.AbstractKernelEventLifecycleEventHandler]
Fired: AbstractEvent@57e77308{source=org.jboss.kernel.plugins.event.AbstractEventManager@1c313f4e
type=org.jboss.system.server.started seq=0 time=1321823426219
context=1321823426219}

IDEA detects server is started and gets... Connected to server
IDEA sends request to the server for the artifact to be deployed and starts waiting for the feedback: [2011-11-20 10:10:26,492] Artifact dms-back-office-web-war:war
exploded: Artifact is being deployed, please wait...

JBoss receives request for and starts the deploy (next 4 entries):
22:10:26,503 DEBUG [org.jboss.deployment.MainDeployer] isDeployed,
url=vfsfile:/home/amorfis/workspace/idea/DMS/aggregated_view/dms-back-office-web/dms-back-office-web-war/target/war/dms-back-office.war/,
state=UNDEPLOYED
22:10:26,510 WARN  [org.jboss.deployment.MainDeployer] undeploy
'file:/home/amorfis/workspace/idea/DMS/aggregated_view/dms-back-office-web/dms-back-office-web-war/target/war/dms-back-office.war/'
: package not deployed
22:10:26,513 DEBUG [org.jboss.deployment.MainDeployer] isDeployed,
url=vfsfile:/home/amorfis/workspace/idea/DMS/aggregated_view/dms-back-office-web/dms-back-office-web-war/target/war/dms-back-office.war/,
state=UNDEPLOYED
22:10:26,516 INFO  [org.jboss.deployment.MainDeployer] deploy,
url=file:/home/amorfis/workspace/idea/DMS/aggregated_view/dms-back-office-web/dms-back-office-web-war/target/war/dms-back-office.war/
22:10:26,517 DEBUG [org.jboss.deployers.plugins.main.MainDeployerImpl]
Add deployment:
vfs:///home/amorfis/workspace/idea/DMS/aggregated_view/dms-back-office-web/dms-back-office-web-war/target/war/dms-back-office.war
)

And that artifact is reported as deployed right after JBoss reports this on its log:

(
JBoss reports the artifact is deployed: 22:15:15,181 DEBUG
[org.jboss.web.tomcat.service.deployers.TomcatDeployment] Initialized:
{WebApplication:
/home/amorfis/workspace/idea/DMS/aggregated_view/dms-back-office-web/dms-back-office-web-war/target/war/dms-back-office.war/,
URL: file:/home/amorfis/workspace/idea/DMS/aggregated_view/dms-back-office-web/dms-back-office-web-war/target/war/dms-back-office.war/,
classLoader: BaseClassLoader@7459c4c6{vfs:///home/amorfis/workspace/idea/DMS/aggregated_view/dms-back-office-web/dms-back-office-web-war/target/war/dms-back-office.war}:1952040134}
jboss.web:j2eeType=WebModule,name=//localhost/dms-back-office,J2EEApplication=none,J2EEServer=none

IDEA receives feedback from the server, that the artifact is deployed: [2011-11-20 10:15:15,186] Artifact dms-back-office-web-war:war exploded: Artifact is deployed successfully deployed
)


Could it be, that artifact isn't deployed due an issue in its initialization code?
I suspect, shutdown procedure may break an endless loop in the artifact's code, so the artifact's deployment finished and reported during shutdown.
In this case, you shoud be able to debug the code with IDEA.

Regards,
Michael

0

Could it be, that artifact isn't deployed due an issue in its initialization code?

Hmm... If this was the case, would it be possible to deploy it manually, i.e. by copying .war file to <jboss>/server/<server>/deploy directory? I think it shouldn't work too, but it works.

I suspect, shutdown procedure may break an endless loop in the artifact's code, so the artifact's deployment finished and reported during shutdown.

Probably it is problem in my app, because another app is deployed correctly. However, this app is also deployed correctly by other developers from my team. So it's only me who has a problem :/

In this case, you shoud be able to debug the code with IDEA.

Thanks, I'll try to put breaks in a few places and debug.
0

Would it be any help, if I tell that mvn jboss:deploy also runs without problems?

0

Ok, I found the cuplrit. Of course, it was myself.

I had an method breakpoint. So probably my app would even deploy, if I waited like half an hour, but I wasn't so patient :)

Thanks for your help Michael.

Best regards.

0

Please sign in to leave a comment.