Ctrl-Shift-N not working

Hi,

I'm facing strange problem in my IntelliJ workspace, to fix something i made change in settings after onwards I'm not able to find files when I do Ctrl + Shift + N . I'm able to perform Ctrl + N (which lists java files but not jsp's).
aS Ctrl + Shift + N is not working unable to find jsp files in workspace.

Any help is greatly apprecitaed.

Thanks in advance,

Sudheer


14 comments
Comment actions Permalink

Hello Sudheer,

Press the "Filter" button in the top right hand corner of the Ctrl-Shift-N
popup and make sure that the JSP file type is checked in the list that appears.

I'm facing strange problem in my IntelliJ workspace, to fix something
i made change in settings after onwards I'm not able to find files
when I do Ctrl + Shift + N . I'm able to perform Ctrl + N (which lists
java files but not jsp's).

aS Ctrl + Shift + N is not working unable to find jsp files in
workspace.


--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0
Comment actions Permalink

Hi Dmitry Jemerov,

Thanks for your quick reply. In the filter all the options are checked but still it is not showing either Java or JSP files . It's not showing  any files when I do ctrl +shift +n in the lists.

Please find attched screen shot.

Thanks,
Sudheer



Attachment(s):
screenshot.jpg
0
Comment actions Permalink

Hello Sudheer,

Please try to use File | Invalidate Caches and restart IntelliJ IDEA.

Thanks for your quick reply. In the filter all the options are checked
but still it is not showing either Java or JSP files . It's not
showing  any files when I do ctrl +shift +n in the lists.

Please find attched screen shot.


--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


7
Comment actions Permalink

Dmitry Jemerov,

Many Thanks. Its working now.

Regards,

Sudheer

0
Comment actions Permalink

Hi Dmitry,

Thank you. I faced the same issue and it resolved with your idea.

0
Comment actions Permalink

I use IntelliJ IDEA 2017.2.4 Build #IU-172.4155.36 on Mac OSX and experience the same recurring issue. Every few hours I have to invalidate cache / restart the IDE as soon as Cmd-Shift-O stops showing my project files.. filtering not the issue..

Looks like the original issue has been around almost 7 years.. is there any chance this can be fixed someday?

Many Thanks.

3
Comment actions Permalink

The same is happening with LexLuthor is happenning with me, probably is a bug of IntelliJ IDEA 2017.2.4 Build #IU-172.4155.36, because I'm using Ubuntu.

0
Comment actions Permalink

The same issue, PHPStorm 2017.2.4 Build #PS-172.4155.41, macOS Sierra 10.12.6.

1
Comment actions Permalink

Hello Ivan,

Does "File | Invalidate caches" help? Could you please report new issue on YouTrack attaching idea.log ("Help | Show Log in...) after facing the issue again:  http://youtrack.jetbrains.com/issues/IDEA ?

 

1
Comment actions Permalink

Hello Yaroslav,

Yes, "Invalidate caches" helps, but I need to perform this operation at least once a day to make "find file"/"find class"/"find anything" features work. Next time this problem happens I'll report a new issue on YouTrack.

1
Comment actions Permalink

The same issue is happening for me in PhpStorm 2017.2.4 Build #PS-172.4155.41 on macOS High Sierra 10.13: Navigate to File (Cmd-Shift-O) doesn't find files in my project; after I select File > Invalidate Caches / Restart... it fixes the issue temporarily, but as soon as I quit PhpStorm and open it again, the issue returns. It's not an issue with the Filter being selected.

Is this a bug in PhpStorm, or is it an issue with corruption in my project files / .idea folder? Either way, it seems enough people are having this issue it must be an issue beyond just my project settings files being corrupt... Any thoughts on a fix?

0
Comment actions Permalink

Could you please attach logs in comments to this issue: https://youtrack.jetbrains.com/issue/IDEA-181404 ?

0
Comment actions Permalink

I've attached my log files as a comment on that issue, here: https://youtrack.jetbrains.com/issue/IDEA-181404#comment=27-2542348

0
Comment actions Permalink

I had my IDE lock onto Kotlin files for ctrl+n. Running File -> Invalidate cache like Dmitry suggested solved it for now.

Edit: I tried to edit the filter option, but all was checked.

0

Please sign in to leave a comment.