"Please specify a Android SDK"

I've installed IDEA 10.5.2 Community edition to Ubuntu 11.10.
I've installed Sun Java 6.
Downloaded Android SDK.
Configured SDK for Java 1.6 inside IDEA.
Configured Android SDK that uses the above mentioned 1.6.
Imported my Maven Android project.
Running the maven tasks work fine (even the android:deploy) but:

The ADB Logcat screen shows no devices and when I click it says "Please specify an Android SDK".

Any ideas what could be wrong? I found an old ticket with pretty much exactly these symptoms (importing Maven android project causes "Please specify android sdk" message) but it's supposed to be fixed already in 10.5 release candidate.

Please sign in to leave a comment.