Bug? idea changes my shutdown script every time

My IDEA version: 10.5.2
I changed all ports of JBoss 5 AS, so i need customize the shutdown script.
Default is : C:\jboss-6.1.0.Final\bin\shutdown.bat -s service:jmx:rmi:///jndi/rmi://localhost:1090/jmxrmi -S
What I need: C:\jboss-6.1.0.Final\bin\shutdown.bat -s service:jmx:rmi:///jndi/rmi://localhost:1190/jmxrmi -S
I unchecked the Use default checkbox and typed my script into the textbox, clicked Apply, closed the window and reopened it, the script is changed to
C:\jboss-6.1.0.Final\bin\shutdown.bat -s service:jmx:rmi:\\\jndi\rmi:\\localhost:1190\jmxrmi -S
Is that a bug? So how can I type "/" in script textbox?

thanks.


Btw. the deploy doesn't work any more, after the port changing.
To reproduct the problem, just change all ports with Service Binding Manager in JBoss Administrator Console.
I changed the ports back and use the default stop scripts, all work again.

Please sign in to leave a comment.