How to stop webapp files being copied over to exploded dir on compile

In compiler settings, I have "Deploy web applications to server after compilation" set to "None". However, each time I compile a java class, my entire web app is copied over to its exploded directory. I have "synchronize exploded directory" unchecked in Module Settings. Anyone know how to fix this?

4 comments

Check Settings | Compiler | Deploy web applications to server after
compilation. This may help.


Kashif Noorani wrote:

In compiler settings, I have "Deploy web applications to server after compilation" set to "None". However, each time I compile a java class, my entire web app is copied over to its exploded directory. I have "synchronize exploded directory" unchecked in Module Settings. Anyone know how to fix this?



Attachment(s):
moz-screenshot.jpg
0

Hi Norris,

Thanks for the screenshot. I have the exact same settings, as I mentioned in my original email.

I am assuming that IDEA doesn't behave like this for you and that it does honor the compiler settings. Are you on 3516?

0

3516 also. What about the honor dependencies on the compiler tab?

Kashif Noorani wrote:

Hi Norris,

>

Thanks for the screenshot. I have the exact same settings, as I mentioned in my original email.

>

I am assuming that IDEA doesn't behave like this for you and that it does honor the compiler settings. Are you on 3516?

0

Please sign in to leave a comment.