Position cursor at end of line

Answered

How do I get IntelliJ to position the cursor at the end of a line when I click or move the cursor with the arrow keys?  By default it places it where I click, or directly above/below where it last was in the case of arrow key usage.  This is pretty annoying because it means I can't just start typing.

7 comments
Comment actions Permalink

Just deactivate that really annoying feature: "File -> Settings -> IDE Settings -> Editor -> Allow placement of caret after end of line"

5
Comment actions Permalink

Thank you!  Very infurating "feature" disabled!

0
Comment actions Permalink

So happy to have this answer that I just had to register in the forum to say thanks!  

0
Comment actions Permalink

thanks mate, it really helps

0
Comment actions Permalink

+1 ...owe you a pint for that one mate!

0
Comment actions Permalink

Could also be "Column Selection Mode" thats what it was for me. Right click where your typing your code and unselect it. 

0
Comment actions Permalink

Thanks Stetson Wood -- it was Column Selection Mode for me as well! 

0

Please sign in to leave a comment.