gwt developer console running outofmemory right away!

Hey,

been using the gwt plugin in eclipse for about a year, has worked pretty fine.

However, i recently upgraded to OSX lion, and i also upgraded intellij to latest version.

Now, i have a standard gwt project. I have historically been able to start it with the devconsole, change stuff and reload page in firefox.

But now, i can only start it, but as soon as i reload page, devconsole crashed. Yesterday it just hung, this morning i upgraded to GWT2.4 and now i just get permgen space outofmemory on first reload. I have the memory settings set to 1024m!


If someone could give me pointers it would me much appreciated...

2 comments
Comment actions Permalink

Hello,

are you sure that you used proper JVM parameter to increase memory size? Size of permgen is specified by -XX:MaxPermSize paramater, not by -Xmx.


--
Nikolay Chashnikov
Software Developer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

0
Comment actions Permalink

Hey Nikolay, thanks for quick response.

Yeah, you are right, saw it after i posted... Thanks.


However, what i've done now is i tried changing the user.agent to safari and run with Chrome instead. I'm at about 30 reloads now and not a single console crash!It also gwt-recompiles quite a bit faster than what it did in firefox.

I have no idea why it works so crappy with FF...

0

Please sign in to leave a comment.