What version of HTML for HtML and JSP page parsing does IDEA 5 support?

Does anybody know what version of HTML IDEA 5 uses when parsing HTML and JSP pages? It seems like it does not recognize certain tags that are recognized by IE - nobr tag, for instance. Is the HTML version for parsing configurable?

Any help is appreciated. AG.

1 comment

Hi,

IDEA uses HTML4.
One can change the version used via dtd declaration or via external
resource mapping of 'http://www.w3.org/1999/xhtml' to dtd/schema you want

Alexander Gurvits wrote:

Does anybody know what version of HTML IDEA 5 uses when parsing HTML and JSP pages? It seems like it does not recognize certain tags that are recognized by IE - nobr tag, for instance. Is the HTML version for parsing configurable?

Any help is appreciated. AG.



--
Best regards,
Maxim Mossienko
IntelliJ Labs / JetBrains Inc.
http://www.intellij.com
"Develop with pleasure!"

0

Please sign in to leave a comment.