Redraw problems?

Is it just me? See attachment. Notice the location of quotes before or on top of equals and how location of cursor messes up the code underneath. Also, when I type or move the cursor, the tag attributes move around. That is, they move a couple pixels horizontally.

18 comments

It seems to be a font issue. If I switch to a monospaced font the problems go away. Just can't find a monospaced font I like:(

0

Is anyone else seeing this? I've gotta get my ProFont back.

0

I'm using Andale Mono and I've experienced problems too when there is
bold text and when using tab character.

See http://www.jetbrains.net/jira/browse/IDEA-4205

BoD

Brad L. wrote:

Is anyone else seeing this? I've gotta get my ProFont back.

0

Should be fixed in latest 3489.
-


Maxim Shafirov
http://www.jetbrains.com
"Develop with pleasure!"

Is it just me? See attachment. Notice the location of quotes before
or on top of equals and how location of cursor messes up the code
underneath. Also, when I type or move the cursor, the tag attributes
move around. That is, they move a couple pixels horizontally.



0

Definitely not fixed in 3489. Although, if I turn off all bold formatting
(i.e. - java keywords, Strings, xml tags and attributes) then the problems
go away.

"Maxim Shafirov (JetBrains)" <max@jetbrains.com> wrote in message
news:c8a8a1bf14d028c788e0c1f27e10@news.jetbrains.com...

Should be fixed in latest 3489.
-------------------
Maxim Shafirov
http://www.jetbrains.com
"Develop with pleasure!"

>
>> Is it just me? See attachment. Notice the location of quotes before
>> or on top of equals and how location of cursor messes up the code
>> underneath. Also, when I type or move the cursor, the tag attributes
>> move around. That is, they move a couple pixels horizontally.
>>
>



0

Actually, turning off bold highlighting for xml attribute names and java
keywords seems to fix most, if not all, problems.

"Brad" <brad@somewhere.com> wrote in message
news:dgegq0$mq3$1@is.intellij.net...

Definitely not fixed in 3489. Although, if I turn off all bold formatting
(i.e. - java keywords, Strings, xml tags and attributes) then the problems
go away.

>

"Maxim Shafirov (JetBrains)" <max@jetbrains.com> wrote in message
news:c8a8a1bf14d028c788e0c1f27e10@news.jetbrains.com...

>> Should be fixed in latest 3489.
>> -


>> Maxim Shafirov
>> http://www.jetbrains.com
>> "Develop with pleasure!"
>>
>>> Is it just me? See attachment. Notice the location of quotes before
>>> or on top of equals and how location of cursor messes up the code
>>> underneath. Also, when I type or move the cursor, the tag attributes
>>> move around. That is, they move a couple pixels horizontally.
>>>
>>
>>
>



0

This is not fixed. Should I file a Jira?

0

This is not fixed. Should I file a Jira?


I can confirm this to be the same on my os x box. I don't see this problem
on windows though.

R


0

What font are you using?

"Robert Sfeir" <nomail@jetbrains.com> wrote in message
news:7c2dbfd112d468c78b31e674a9d1@news.jetbrains.com...
>> This is not fixed. Should I file a Jira?
>

I can confirm this to be the same on my os x box. I don't see this
problem on windows though.

>

R

>



0

What font are you using?


Verdana on windows, Monaco on the Mac.

R


0

If I use a font size of 10 with Verdana I still have the problems in xml/jsp
files where attribute names "jump" back and forth when I move the cursor and
this causes the attribute names to be "garbled". This only happens when the
attribute(name and value) is on it's own line and it's not just the
attribute that the cursor is on but can be one or more attributes in tags
above the one I click. But, if I switch the font size to 11, all is good.

"Robert Sfeir" <nomail@jetbrains.com> wrote in message
news:7c2dbfd1130ab8c78b3ce460383a@news.jetbrains.com...
>> What font are you using?
>

Verdana on windows, Monaco on the Mac.

>

R

>



0

I have this issue too. It has been driving me NUTS. It is only in
HTML/JSP/XML files not JAVA.


" Brad L." <no_mail@jetbrains.com> wrote in message
news:32568433.1126855272961.JavaMail.javamailuser@localhost...

Is anyone else seeing this? I've gotta get my ProFont back.



0

Well, I finally managed to reproduce the problem (thanks a lot guys). The
reason is actually quite funny and caused by some bulk drawing optimization
we've made plus the fact the mentioned fonts (Verdana 10, ProFont) have different
size of the space character in bold vs. plain version. Definetely not the
behaivor we used to expect from the font family...

-


Maxim Shafirov
http://www.jetbrains.com
"Develop with pleasure!"


0

Great! When's the next build?

"Maxim Shafirov (JetBrains)" <max@jetbrains.com> wrote in message
news:c8a8a1bf14edc8c78c0ed89bd8b9@news.jetbrains.com...

Fixed.
-------------------
Maxim Shafirov
http://www.jetbrains.com
"Develop with pleasure!"

>



0

Tomorrow morning, if nothing wrong happens.
-


Maxim Shafirov
http://www.jetbrains.com
"Develop with pleasure!"

Great! When's the next build?

"Maxim Shafirov (JetBrains)" <max@jetbrains.com> wrote in message
news:c8a8a1bf14edc8c78c0ed89bd8b9@news.jetbrains.com...

>> Fixed.
>> -


>> Maxim Shafirov
>> http://www.jetbrains.com
>> "Develop with pleasure!"


0

Please sign in to leave a comment.