Click anywhere and cursor is put there

Answered

Sorry this is a tuff one to explain. When using the application if I click somewhere on any line it will put the cursor that that exact location. I am use to it putting the cursor at the end of line. Again sorry for the bad explaination.

10 comments
Comment actions Permalink

http://www.jetbrains.com/idea/documentation/migration_faq.html

"In Eclipse, virtual space (the possibility to place the caret after the end of a line) is disabled by default, which is contrary to IntelliJ IDEA default setting.
To alter it, go to Settings dialog, Editor and clear the Allow placement of caret after end of line option."

hope this helps,
cheers

0
Comment actions Permalink

Thank you that worked so well.

0
Comment actions Permalink

Sorry for necroing this thread, but I just had an incident where this behaviour would suddenly kick in, and I checked my settings, and the checkbox for "Allow placement of caret after end of line" was unchecked. Did I accidentally hit some kind of shortcut for this? What would that shortcut be?

Luckily, a restart of PhpStorm solved the issue and I'm back to placing the caret at the end of the line again, but it would be nice to avoid exiting PhpStorm in the future, as I have to build the kubernetes environment on startup and it takes a couple of minutes. :)

2
Comment actions Permalink

Hi Adrian,

There is no specific shortcut for toggling this behavior. Third-party plugins may be interfering, so you can first check if disabling all or specific downloaded plugins under File | Settings | Plugins > Installed will help.

1
Comment actions Permalink

I actually updated the plugin Cloud Code right before this happened (still hadn't restarted to apply the update), so that may be it! Anyway, it worked as soon as I had restarted, so let's hope I will be unable to reproduce it in the future! ;)

0
Comment actions Permalink

For future readers who might stumble across the same problem. Although the particular switch “Allow placement of caret after end of line” has no shortcut by default, an option which results in a similar behavior does: “Column Selection Mode”, Alt + Shift + Insert. So you might be looking for that one if your cat rolled over the keyboard.

16
Comment actions Permalink

Thanks you so much Lazar Ljubenović , you save me each time I change tab, forget to lift my finger pushing Alt key, insert a copied line and wonder why my Pycharm is f*cked up.

1
Comment actions Permalink

Thanks Lazar! That was the issue for me as well

1

Please sign in to leave a comment.